Echo and mixmonitor

I am using a PRI T1. I am using to accept inbound and outbound to PSTN. Everything seems fine. When I use mixmonitor to record conversation, the callee can hear a little bit of echo.

Anyone has experienced this issue? and how do you fix it.


-= Info about application ‘MixMonitor’ =-

Record a call and mix the audio during the recording


Records the audio on the current channel to the specified file.
If the filename is an absolute path, uses that path, otherwise
creates the file in the configured monitoring directory from
asterisk.conf. Use of StopMixMonitor is required to guarantee
the audio file is available for processing during dialplan execution.

Valid options:
a - Append to the file instead of overwriting it.
b - Only save audio to the file while the channel is bridged.
Note: Does not include conferences or sounds played to each bridged
Note: If you utilize this option inside a Local channel, you must
make sure the Local channel is not optimized away. To do this,
be sure to call your Local channel with the ‘/n’ option.
For example: Dial(Local/start@mycontext/n)
v() - Adjust the heard volume by a factor of (range -4 to 4)
V() - Adjust the spoken volume by a factor of (range -4 to 4)
W() - Adjust the both heard and spoken volumes by a factor of
(range -4 to 4)

will be executed when the recording is over
Any strings matching ^{X} will be unescaped to ${X}.
All variables will be evaluated at the time MixMonitor is called.
The variable MIXMONITOR_FILENAME will contain the filename used to record.

Try the v or V options first. If that fails, try adjusting rxgain or txgain.

Thanks for your advise. I tried both v and V (with different combo -4,0,4)
and rxgain and txgain option in chan_dahdi.conf, but it doesn’t help.

The callee side still hear echo with mixmonitor.

Again, without mixmonitor, caller and callee doesn’t hear echo.

I have tried software echocan (mg2), but it doesn’t help either.

I wonder if this is a bug in mixmonitor…

have you considered monitor instead of mixmonitor? Also, is echocancelwhenbridged=yes in dadhi/zaptel.conf?

In fact, I tried monitor before mixmonitor.

I made an apple-to-apple comparison calling my Landline to mobile phone
with and without Monitor. And callee heard echo when using Monitor.

Yes, I have echocancelwhenbridged=yes in chan_dahdi.conf

have you checked the bug reports? Out of thousand or so entries there, you can usually find a similar problem and sometimes a resolution.