DTMF suddenly dont work in any way


#1

Hello,

I’ve asterisk 1.2. A few weeks ago extended functions like transfer with # or callparking works well.

Today I tried to implement a callthrough-function and get never a result. So I test # and callparking - and they also dont work.

I have test all possible dmtfmode, but no success.

Maybe I’ve change some important configuration in the last weeks, but I dont rember. Is there any parameter to switch on/off the recognize of dtmf?

Thanks for every hint

Joachim


#2

Try calling VoicemailMain and seeing if you can enter the mailbox and password. If you can, DTMF isn’t broken.

If you are using SIP phones check to see if you set dtmfmode=info, this breaks voicemail

I’m having the same problems you are with DTMF on sip phones.


#3

Hi,

I am connecting to my own * server in the same LAN using a java client. The conection is working. I tried adding some functionality to send DTMF by SIP INFO but the server seems to not understand it. I get this:

-- Playing 'vm-helpexit' (language 'en')

sip debug
SIP Debugging enabled
*CLI>
<-- SIP read from 192.168.0.83:9552:
INFO sip:192.168.0.117:5060;transport=udp SIP/2.0
Call-ID: e0b44a5765c4285ae821b76ade69c477@192.168.0.83
CSeq: 1 INFO
From: sip:mcr@192.168.0.117;transport=udp;tag=8143
To: sip:sip:111@192.168.0.117;transport=udp
Via: SIP/2.0/UDP 192.168.0.83:9552;branch=885592977
Max-Forwards: 70
Contact: sip:mcr@192.168.0.83:9552;transport=udp
Content-Type: application/dtmf-relay
Content-Length: 21

Signal=1
Duration=170
— (10 headers 2 lines)—
Transmitting (no NAT) to 192.168.0.83:9552:
SIP/2.0 503 Server error
Via: SIP/2.0/UDP 192.168.0.83:9552;branch=885592977;received=192.168.0.83
From: sip:mcr@192.168.0.117;transport=udp;tag=8143
To: sip:sip:111@192.168.0.117;transport=udp;tag=as0f15c3da
Call-ID: e0b44a5765c4285ae821b76ade69c477@192.168.0.83
CSeq: 1 INFO
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Contact: sip:111@192.168.0.117
Content-Length: 0


-- Playing 'vm-onefor' (language 'en')

I couldn’t notice that I have no INFO in the Allow: header. Can you shed some light on this issue?

in sip.conf I have:

[mcr]
type=friend
secret=mcr
context=from-sip
host=dynamic
;nat=no
canreinvite=no
dtmfmode=info
;call-limit=1
;mailbox=1234@default
disallow=all
allow=alaw
allow=ulaw
allow=gsm
;allow=g723.1

Thank you,
Mircea


#4

Found the problem. Our application was retrieving the wrong sip dialog in order to perform the operation.