DTMF Issue

In my dial plan I’m forwarding a call that comes in to an external number.

Caller call’s DID -> Hist Asterisk Server -> Asterisk Server sends call back out trunk to ext number -> call connects with ext number

this works fine, at the destination end they have an IVR that echo’s DTMF tones pressed in order to help me diagnose the issue I’m having.

If I press any digit 0-9 or the pound key the endpoint immediately reports the digit pressed. If I press the * key it delays 5-6 seconds before it registers on the endpoint. If I call the ext termination number from my land line (provided by telco) all the keys including * report immediately so it seems asterisk is waiting to process something when it see’s * pressed. How can I prevent this and have it pass on the dtmf immediately like the other numbers.


Asterisk has been enabled to look for feature codes, and you have features codes beginning with * defined.

Remove all options from the Dial application call that would require Asterisk to look for feature codes (e.g. T,t, H, h, etc.

I have my sip trunk defined and the following dial plan and all digits are immediate however “*” (Star) key is delayed by 5 - 6 seconds.


exten => 5555555555,1,Set(__FROM_DID=${EXTEN})
exten => 5555555555,n,Set(CDR(did)=${FROM_DID})
exten => 5555555555,n,ExecIf($[ “${CALLERID(name)}” = “” ] ?Set(CALLERID(name)=${CALLERID(num)}))
exten => 5555555555,n,Set(__CALLINGPRES_SV=${CALLERPRES()})
exten => 5555555555,n,Set(CALLERPRES()=allowed_not_screened)
exten => 5555555555,n,Dial(SIP/GATE_LINK/6666666666,300,)

here the dial plan is forwarding 5555555555 (inbound call) to 6666666666 (ext termination number)
on the sip trunk GATE_LINK

I looked everywhere and can’t see any feature codes or Dial options set. Could it be a module loaded causing this problem? Do I have to set some default variables in the Dial plan to stop this?

I suspect the problem is outside Asterisk.

Enable dtmf debugging in logger.conf and set the verbose level to 5, then provide the combined verbose and DTMF logging, from a log file, not from the console, as the console does not include all the timestamps.

I added dtmf to both console and the full log and then reloaded. the following is shown in asterisk

devVoip2*CLI> logger show channels
Channel Type Status Configuration

/var/log/asterisk/full File Enabled - NOTICE WARNING ERROR VERBOSE DTMF FAX
/var/log/asterisk/messages File Enabled - NOTICE WARNING ERROR
/var/log/asterisk/debug File Enabled - DEBUG VERBOSE DTMF

however I do not see DTMF messages on the console or in the full log. I have no idea what’s going on?

more debug,

I run features show and get the following:

Builtin Feature Default Current

Pickup *8 *8
Blind Transfer # #
Attended Transfer
One Touch Monitor
Disconnect Call * *
Park Call
One Touch MixMonitor

Dynamic Feature Default Current


Feature Groups:


Call parking (Parking lot: default)

Parking extension : 700
Parking context : parkedcalls
Parked call extensions: 701-750
Parkingtime : 45000 ms
MusicOnHold class : default
Enabled : Yes

I believe these may be causing the problem but they are not defined in my features.conf I can’t find them defined anywhere they seem built in like it says… how can I disable them?

As far as I can tell, *8 is not used mid-call and * is only detected if the dial h/H options are used.

I would try turning up debugging until you do see some DTMF debug output.

I’d also check whether the call is being natively bridged, as, if it is, Asterisk will not be doing anything at all with the DTMF.