Does /var/run/asterisk/asterisk.ctl exist


I have asterisk 11.25
I did a core restart now and after that asterisk keeps stopping

if I run asterisk -cvvvv , asterisk starts and stops but sometimes give error “privilege escalation protection disabled asterisk”

If I run asterisk -rvvvv it gives error “Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)”

ownership for /var/run/asterisk is root and if I try to change
chown -R asterisk /var/run/asterisk
chown: invalid user: ‘asterisk’

SELinux is disabled

I think there was issue with cdr table, I disabled it and it started.

But still for some extensions its giving me
Everyone is busy/congested at this time (1:0/0/1)

sip debug shows 404, but peer is reachable and outbound calls are working

– Called SIP/206

<— SIP read from UDP:116.58.x.x:1231 —>
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 176.9.x.x:50xx;branch=z9hG4bK6b20bf2a;rport
From: “206–222” sip:222@176.9.x.x:50xx;tag=as5009b00f
To: sip:206@116.58.x.x;transport=udp
Call-ID: 7454e104376297e41fedb98f4c6e62c2@176.9.x.x:50xx
Date: Tue, 24 Sep 2019 15:58:39 GMT
CSeq: 102 INVITE
Content-Length: 0

— (8 headers 0 lines) —
Transmitting (NAT) to 116.58.x.x:1231:
ACK sip:206@116.58.x.x;transport=udp SIP/2.0
Via: SIP/2.0/UDP 176.9.x.x:50xx;branch=z9hG4bK6b20bf2a;rport
Max-Forwards: 70
From: “206–222” sip:222@176.9.x.x:50xx;tag=as5009b00f
To: sip:206@116.58.x.x;transport=udp
Contact: sip:222@176.9.x.x:50xx
Call-ID: 7454e104376297e41fedb98f4c6e62c2@176.9.x.x:50xx
CSeq: 102 ACK
User-Agent: Asterisk PBX 11.25.1
Content-Length: 0

Scheduling destruction of SIP dialog ‘7454e104376297e41fedb98f4c6e62c2@176.9.x.x:50xx’ in 15808 ms (Method: INVITE)
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [206@outbound1:3] Macro(“SIP/222-000001d0”, “vmtech,206”) in new stack
– Executing [s@macro-vmtech:1] VoiceMail(“SIP/222-000001d0”, “206@vmtech”) in new stack

404 would be extension not found in context.

extension is reachable and able to make outbound calls. but getting busy / congested when try dial to that extension whereas issue with context gives error “extension not found in context”,

Extensions cannot make outbound calls! They are dial plan constructs which receive calls.

Oh okay, but sip show peers is showing me its registered

sip show peer 200 output is

  • Name : 200
    Description :
    Secret :
    MD5Secret :
    Remote Secret:
    Context : outbound
    Record On feature : automon
    Record Off feature : automon
    Subscr.Cont. :
    Language :
    Tonezone :
    AMA flags : Unknown
    Transfer mode: open
    CallingPres : Presentation Allowed, Not Screened
    Callgroup :
    Pickupgroup :
    Named Callgr :
    Nam. Pickupgr:
    MOH Suggest :
    Mailbox :
    VM Extension : asterisk
    LastMsgsSent : 0/0
    Call limit : 0
    Max forwards : 0
    Dynamic : Yes
    Callerid : “” <>
    MaxCallBR : 384 kbps
    Expire : 3559
    Insecure : no
    Force rport : Yes
    Symmetric RTP: Yes
    ACL : Yes
    DirectMedACL : No
    T.38 support : No
    T.38 EC mode : Unknown
    T.38 MaxDtgrm: 4294967295
    DirectMedia : Yes
    PromiscRedir : No
    User=Phone : No
    Video Support: No
    Text Support : No
    Ign SDP ver : No
    Trust RPID : No
    Send RPID : No
    TrustIDOutbnd: Legacy
    Subscriptions: Yes
    Overlap dial : No
    DTMFmode : rfc2833
    Timer T1 : 500
    Timer B : 32000
    ToHost :
    Addr->IP : 116.58.x.x:1250
    Defaddr->IP : (null)
    Prim.Transp. : UDP
    Allowed.Trsp : UDP
    Def. Username: 200
    SIP Options : (none)
    Codecs : (g729)
    Codec Order : (g729:20)
    Auto-Framing : No
    Status : OK (318 ms)
    Useragent : Cisco-CP7960G/8.0
    Reg. Contact : sip:200@116.58.x.x;transport=udp
    Qualify Freq : 60000 ms
    Keepalive : 0 ms
    Sess-Timers : Accept
    Sess-Refresh : uas
    Sess-Expires : 1800 secs
    Min-Sess : 90 secs
    RTP Engine : asterisk
    Parkinglot :
    Use Reason : No
    Encryption : No

Please suggest what can I do to resolve this issue

Provide the correct context for the incomign peer, or provide an extension in the existing context, for that peer, that matches the digits it is sending.

@david551 here is complete scenario

Everything was running smooth since last 2 years. today we were unable to dial one extension and some channels were stuck so I did core restart now, after that DB Table named cdr crashed so I disabled it and was able to start asterisk. Now I’m unable to dial most of the extensions (I’m able to dial a few), so it can’t be a context issue

Also if digits are not matched, shouldn’t it give error “extension not found in context”?

I configured the same extension on softphone and its working, but not on cisco 7960 / 7940. Not sure why suddenly stopped working on cisco phones

Solved the issue, For some reason my router was blocking connections randomly

Thank you for your help @david551

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.