Disable outbound naptr

I’m using pjsip.conf and doing an outbound call. I have endpoint configured in pjsip.conf with srv_lookups=no (loaded with pjsip reload), but still naptr/srv lookups are occurring. How can I disable naptr/srv on target domain for outbound call,
thankyou.

That option only controls the “identify” section. There is no explicit option to disable NAPTR lookups. Why exactly do you wish to do so?

NAPTR lookups are causing excessive delays in call setup as there are no NAPTR records setup on our sip provider. We want to just do plain DNS lookups.

Assuming the SOA for the provider has a sensible time to live setting, run your own caching nameserver, which should negative cache most of the enequires.

  1. Yell at your SIP provider :slight_smile:
  2. (Just guessing…) Set up iptables rules to reject NAPTR lookups faster.

About which SIP provider are we talking?