Dial function problem

hi all,

my dial function doesn’t jump to n+101 when the line is busy.
in my test example n=1

exten => 6001,1,Dial(SIP/nAGI,10)
exten => 6001,2,VoiceMail(u6001@default)
exten => 6001,102,VoiceMail(b6001@default)

any idea?


I believe that was the default behavior back in 1.0. However I believe in 1.2 that they switched away from using the +101 concept. You should instead access the status of the call via the $DIALSTATUS variable. You can learn more about it by typing command at the Asterisk console.show application Dial

If you have the samples installed, look in your extensions.conf for the [macro-stdexten] section. It has an example using $DIALSTATUS.

Thanks a lot for your help.


you could revert back to the ‘n+101’ with autofallthrough=no in extensions.conf at the top.

no to get the n+101 you need either the j flag or priorityjumping=yes. autofallthrough=no just makes people not get disconnected when they fall off the end of the dialplan


thanks IronHelix for correcting me, I had it wrong :smiley: