Dial after IAX does not act


#1

iax.conf

[code][general]
port=5036
bandwidth=high
allow=alaw
notransfer=yes
register => login:haslo@centrala.tlenofon.pl
register => numer:haslo@iax2.fwdnet.net

[adam]
type=user
secret=haslo
auth=plaintext
host=dynamic
callerid=Adam Piorko <0>
context=default
allow=alaw
[/code]

extensions.conf

Such configuration does not act.
Why?
I ring across user adam normally.


#2

What does “does not act” mean? What does it do? What doesn’t it do?

This looks wrong to me:

There shouldn’t be a space between the “,” and the “30” and the “||” doesn’t make sense. Try this instead:

exten => 1,2,Dial(IAX2/adam,30,m)


#3

It does not act even.
exten => 1,2,Dial(IAX2/adam)


#4

Please post the output from a verbose CLI.


#5

Oct 30 00:50:59 NOTICE[2769]: app_dial.c:759 dial_exec: Unable to create channel of type ‘IAX2’


#6

We’ll need more than just that one line. Do set verbose 4 , if you haven’t already, and post all the CLI messages relating to that call.


#7

asterisk -R

Asterisk 1.0.7-BRIstuffed-0.2.0-RC7k, Copyright © 1999-2004 Digium.
Written by Mark Spencer markster@digium.com

Connected to Asterisk 1.0.7-BRIstuffed-0.2.0-RC7k currently running on icarus (pid = 9113)
Oct 30 09:33:25 NOTICE[26530]: app_dial.c:759 dial_exec: Unable to create channel of type ‘IAX2’
– Recording the message
– x=0, open writing: /var/spool/asterisk/voicemail/poczta/123/INBOX/msg0003 format: wav49, 0x8199de8
– x=1, open writing: /var/spool/asterisk/voicemail/poczta/123/INBOX/msg0003 format: gsm, 0x8184708
– x=2, open writing: /var/spool/asterisk/voicemail/poczta/123/INBOX/msg0003 format: wav, 0x819ac00
icarus*CLI>


#8

That doesn’t say very much, does it? You will need to have a look at /var/log/asterisk/messages and see if you can find any clues. If not, you will have to enable debugging and go through the debug output.


#9

this appears


#10

Maybe, but we’re already seen that. It doesn’t tell us anything! What we need to know is why it can’t create that channel. There must be a clue somewhere.