Dahdi Echos Like Crazy

I was using FreeBSD-7.1 with Asterisk- with Zaptel-1.4.6. That was working well but then the porters at FreeBSD decided to remove the wcfxo module from the latest port for zaptel which rendered my X101P card useless. So I rebuilt a new drive using Fedora-10, Asterisk-1.6.4, and Dahdi-2.0.1. The system seem to work just great until I tried to make calls with my SIP phones. The echo was overpowering. I put the old drive back in with the older version of * and zaptel and the phones worked without echoing.

So my question is this: Does Dahdi not have the same echo cancellation features as zaptel and why does the zaptel cancellation work but Dahdi does not?

My dahdi conf files included the echo cancellation lines.


You may well need to tune it again.
fxotune may well need to be run. you can also edit the source to use a different echo canceller if required.


Thanks for your reply. Could you be a little more descriptive with this. I think I can read the fxotune manpage but as for editing the source are you referring to the actual source code for dahdi? I could use a few pointers on how one might find the right place in the code to start looking.

it means, that you can use various combination like mg2,kb1,HPEC if you have a license or OSLEC.

OSLEC is an Open Source Line Echo Canceller which is working great for most of my installation

That’s an interesting idea. I thought that DAHDI used its own echo cancellation properties.

Can you tell me how I would install the open source option?

here’s an idea - did you modprobe to enable DAHDI’s echo cancellers

modprobe dahdi_echocan_mg2 loads mg2
""_sec loads sec