Configure sip port


My service provider accepts SIP INVITE request on port 4060, i.e. non default port.

I configured it in sip.conf file but when i made the call just on the softphone it keeps ringing. I captured the packets with ethreal and found that my Asterisk is sending SIP INVITE request on port 5060 instead of port 4060.

Is there anything other than sip.conf to configure. Or what the correct way to configure sip.conf.


You should put port = 4060 in your peer configuration in sip.conf (or users.conf)

I already tried with this option, i.e. port=4060.

BTW, is there anything to do with bindport under general context.

I want to listen on port 5060 and send calls to port 4060. Can I do that.


bindport is the port you’re listening on, keep it 5060.

Post your peer configuration and sip debug with the REGISTER and/or INVITE attempt.