Confbrige TalkingStatus Event Not Working Properly


Sorry, I couldn’t understand what you mean ?


In order to do talk detection it needs RTP packets to flow. If mute stops RTP packets from being sent to Asterisk it will not work.


You mean there is no RTP packets flowing in my problem scenario. So, I should focus on the reason why these RTP packets not sent by the audio device ?


Based on the past information provided I recall that there were no RTP packets when muted, so yes, it would need to send them.


I created a pcap file using tcpdump command, it seems like rtp packets are empty. It was working well, I don’t understand what is wrong.? I did not changed anything in the source code, I suppose it is related to something configurable or server settings??? I’ve checked previous pcap files while making voice records, all RTP packet payloads are filled. Is there any setting you want me to check ?


I don’t know any setting or something that would alter that. Things generally don’t just start working, though.


Do you have any idea about why RTP packets empty ? By the way, voice record file is created, firstly the conference join announcement is played, then there is no voice until to the end.


I don’t understand what you mean - you haven’t specified the scenario in relation to the packet capture or the empty packets. What is going on?


I am making call recordings using ConfBridge. My scenario was working well but now RTP packets seem empty. here is the flow of call recording scenario ;


If that is RTP from the endpoint then you’d need to look at the endpoint… if it’s not then you need to give more context - you haven’t stated what flow that media is.


It is just about my microphone, I tried the scenario with another client it has worked very well. It took 1.5 day of me :frowning: By the way, there is one more question I would like to ask ; when I mute my microphone, it seems like there is a frame flow from audio hook. Is that normal ?

According to the source code;

struct ast_frame *fr = NULL;
fr = ast_audiohook_read_frame(&rs->audiohook, samples, AST_AUDIOHOOK_DIRECTION_BOTH, AST_FORMAT_SLINEAR);

I am getting frames from audio hook, but although I mute my microphone, it continues to send frame … Does it sound right to you ?


Yes, it depends on where the audiohook is, and what the media flow is. It is entirely possible it would still get called.


What do you mean by saying "Yes, it depends on where the audiohook is " ? Could you please detail your explanation ?


You haven’t given context. If the audiohook is on that specific channel, and as you are doing both as the media you want, and if ConfBridge is in use, then yes - I’d expect it to get called even when muted as ConfBridge is still sending media to you AND the device itself may or may not be sending a silent audio stream to Asterisk.

It’s not easy to give a yes or no answer for such things without that context - because what exactly is going on can change the answer. This also applies in general to seeking help on here - you really need to give the full story and details on things, or else you’ll get the wrong answer or an incomplete one.


Ok I understand what you mean right now. I am making call recording using confbridge. And my goal is not to send voice stream when microphone is muted. There is 3 active channels while making call ;

asterisk-test-server*CLI> core show channels
Channel              Location             State   Application(Data)             
Bridge/0x7f3130008ee s@default:1          Up      (None)                        
SIP/4503-00000000    4502@CommPanelsWithA Up      ConfBridge(4444,,,)           
Bridge/0x7f3130008ee s@default:1          Up      (None)                        
3 active channels
1 active call
1 call processed

When the microphone is muted I don’t want to send stream to asterisk server even if it is a silence voice or stream of bridge channel… Is it possible to make it configurable, sending stream via Confbridge when muted ? And blocking sending silent stream also ?


No, ConfBridge provides a constant stream of media. It’s not configurable.


May it be related to the comfort noise ? I mean, is it possible to disable sending comfort noise ?


Asterisk doesn’t support comfort noise, it expects a constant stream of media - and ConfBridge also sends a constant stream of media, this can’t be disabled.


I am currently using 11.5.0 numbered version. Is comfort noise also not supported for this version ?


It’s not supported in any version.