Compiling zaptel on fedora core 5

I installed fedora core 5

When compiling zaptel, I get the following errors:

make[1]: Entering directory /usr/src/kernels/2.6.15-1.2054_FC5-i686' CC [M] /usr/src/asterisk/zaptel-1.2.4/wcusb.o /usr/src/asterisk/zaptel-1.2.4/wcusb.c:1452: fout: unknown field ‘owner’ specified in initializer /usr/src/asterisk/zaptel-1.2.4/wcusb.c:1452: let op: initialization from incompatible pointer type make[2]: *** [/usr/src/asterisk/zaptel-1.2.4/wcusb.o] Fout 1 make[1]: *** [_module_/usr/src/asterisk/zaptel-1.2.4] Fout 2 make[1]: Leaving directory/usr/src/kernels/2.6.15-1.2054_FC5-i686’
make: *** [linux26] Fout 2

What can be the problem?

thanks in advance

I have the exact same problem with zaptel 1.2.5 on Fedora Core 5.

/usr/src/zaptel-1.2.5/wcusb.c:1452: error: unknown field ‘owner’ specified in initializer
/usr/src/zaptel-1.2.5/wcusb.c:1452: warning: initialization from incompatible pointer type
make[2]: *** [/usr/src/zaptel-1.2.5/wcusb.o] Error 1
make[1]: *** [module/usr/src/zaptel-1.2.5] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.15-1.2054_FC5-smp-i686’
make: *** [linux26] Error 2

Could this be specific to Fedora Core 5?
I have zaptel 1.2.4 on FC4 without problems!

have either of you guys edited the makefile to stop wcusb being compiled and seen whether the outcome is different ? although not a fix, it might mean you can get by, particularly if you don’t need that module.

i have a sneaky feeling that you’ll get the same error in other modules though :confused:

In FC 5, something has been changed concerning USB devices.
(something about the USB driver structure)
That’s what’s causing the problem during compilation of zaptel.

The solution is to upgrade to the latest kernel (using yum).
I have upgrade to 2.6.16.
After that, compilation works fine!




The owner field is removed from struct usb_driver on kernel 2.6.15 onwards.

Comment this out.
/* owner: THIS_MODULE, */


Hi all,

I upgraded and the install worked fine… Upgrade and it will work.

I upgraded the kernel to 2.6.17 and it will not compile. Is there something specific to the 2.6.16 kernel that allows it to compile?