Client loose registration after 6-7 hours (SJPhone)


#1

I am rather new to Asterisk, and I have a rather strange problem, I think.

When I used the free SJPhone softphone client I noticed it was rejected registering after 6-7 hors of logontime. I then tried X-lite softphone klient with the same and different extensions / client log on.

I then tried to reboot the Asterisk deamon with the command “restart gracefully”. This did not help. The telephone were still rejected registering.

Then I rebooted the whole server. Then it was not any problem to register. After some hours the telephone client lost registration and were denyed new registration. Then the whoe server has to be booted again, and so on.

When the SJPhone loose registration it says something strange about a nat firewall. The SJPhone and the Aterisk server is behind a NAT firewall (Smoothwall) and there is no firewall between the Asterisk server and the SJPhone client. There is also no firewall on the Windows PC.

The Asterisk version I use is the preconfigured Centos 3.5 boundle that I downloaded a week ago. (Asteris@home). Everything works ok, I can make outgoung calls (via a iax telephone wendor) and I can receive telephones.

The very strange thing is that I have to reboot the whole server 3-4 times a day to avaid that the clients shall loose registration.

By the way both the Windows and the Asterisk PC’s use fixed local ip’s. When I loose registration on the telephone clients, I still keep connection with the Asterisk server wia web interphace and via ssh.

I will be thankfull for any advice on this stange problem (For me it is wery strange problem. It would be nice if someone knew the answer.)

Best reg Arne, stavanger, Norway.


#2

It lookes like this apear to be a specific SJPhone related problem. I have now tried the logon for some time with x-lite and with a Grandstream hardware adapter. It looks like the connection is lost only when using the SJPhone. It is a pity because SJPhone have rather good soud quality as long as it works.

This problem seems to be more SJPhone specific.

If anybody have good or bad experiences with SJPhone, to be used against Aterisk, please leave a few words.


#3

Not sure if you have checked this yet, but there is a users guide that you can consult.

Click here: sjlabs.com/doc/SJphone%20Guide.pdf


#4

Thanks a lot ! No, I did not know about this manual. Will study it a bit.

By the way, also the X-ten works bether now. Did not know you had to turn on the “send silence” function. That helped a lot on the quality.

Have now also tried a Grandstream adapter and that gave a lot bether sound than any of the softtelephones.

Arne.


#5

Yeah, that’s one of the small limitations of Asterisk running on Linux.

It can’t deal with silence suppression. (yet)

It’s much better dealing with an expected stream of data. It can time events better, and appropriately address the processing needs better.

If it’s suddenly given something to do, then it has nothing to do, then it has something to do, Linux has a tendency to trip over itself. It’s not a real time OS.

Click here to learn more.

realtimelinuxfoundation.org/