chan_misdn not loading


I have problem installing chan_misdn. I am quite new to Linux. It is a fresh install of CentOS (nothing else installed except no machine, yum update and yum update kernel done). I think misdn and misdn_user are correctly installed. I used “install-misdn-mqueue.tar.gz”, and /etc/init.d/misdn-init and misdn generate the .conf files and recognize my card.

My problem is when I launch asterisk with -vc, I get “WARNING[8147]: loader.c:359 load_dynamic_module: Error loading module ‘’: cannot open shared object file: No such file or directory”.

I have ‘’ in /usr/lib and ‘’ in /usr/lib/asterisk/modules. I set read-write permissions to evryone. I tried a link to ‘’ in /usr/lib/asterisk/modules.

I hope the solution is to put a link in the good directory. Can someone tell where to put it?

Thank you for reading.

PS: I think it is another problem, but, who knows : when I try “make portinfo”, i get : “make: *** No rule to make target portinfo.o', needed byportinfo’. Stop.”. I do not care about this problem, except if it help solving the first one.

  1. I would try to use /usr/lib directory.
  2. Doubt, someone needs write permissions to those files
  3. Does ‘asterisk’ user have read-access? exec chmod 444 /usr/lib/
  4. exec ldd /usr/lib/ There’s a chance, this lib wants something more!


Thanks for your help!

It this already the directory where the original lies

Me too, but I am desperate :wink:

No effect, except setting back the old permissions. For information, I launch asterisk as root.

Output : => /lib64/ (0x00002acb7f387000) /lib64/ (0x00000035ea200000)
These 2 files are present and everyone has read permissions

It looks like my problem is solved. I just made yum update kernel and yum update. And now, chan_misdn loads normally. I do not know if it was a bug in the last kernel or misdn but, actually, I do not care :stuck_out_tongue: