Can't load ooh323

CentOS 6.5, Asterisk 11

Trying to make ooh323 module work.
The module is there, I can’t start it though. Getting below error. Anybody know how I can enable ooh323?

[2015-09-01 00:07:47] NOTICE[6045]: chan_ooh323.c:2766 reload_config: Unable to load config ooh323.conf, OOH323 disabled
[2015-09-01 00:07:47] ERROR[6045]: chan_ooh323.c:3901 load_module: Can’t load ooh323 config file, OOH323 Disabled

I havent use ooh323 but check the config file ooh323.conf, the error is making reference to the configuration file

Ok, there was no ooh.323.conf file, so I made one.
However when I do a core show channeltypes, doesn’t show up.
Any ideas why?

Ok almost there.
Had an error in my config file.

Now working on outgoing calls, not on incoming, getting
ERROR[145297]: chan_ooh323.c:1908 ooh323_onReceivedSetup: Unacceptable ip xxxxxxxxx

Ideas?

xxxxxxxxx is not a valid IP address. We are not going to be able to say why if you obfuscate it.

The IP address was 10.1.1.198

It appears to be third party code, so you will probably have difficulty getting anyone to support it here.

However, looking at the code, it seems to be some sort of authentication of usage limit issue, and is at run time, not load time:

user = find_user(p->callerid_name, call->remoteIP); if(user && (user->incominglimit == 0 || user->inUse < user->incominglimit)) { ...... ast_mutex_unlock(&user->lock); } else { if (!OO_TESTFLAG(p->flags,H323_DISABLEGK)) { p->username = strdup(call->remoteIP); p->directrtp = gDirectRTP; p->earlydirect = gEarlyDirect; } else { ast_mutex_unlock(&p->lock); ast_log(LOG_ERROR, "Unacceptable ip %s\n", call->remoteIP);

The flag appears to about whether a gatekeeper is in use, and is controlled by the other side.

Hi,
check wether that a “friend” is defined on both ends:

*** asterisk A ***
[astb]
type=friend
context=from-trunk
ip=10.1.1.200 ; UPDATE with appropriate ip address
port=1720 ; UPDATE with appropriate port
e164=101
qualify=yes

*** asterisk B ***
[asta]
type=friend
context=from-trunk
ip=10.1.1.100 ; UPDATE with appropriate ip address
port=1720 ; UPDATE with appropriate port
e164=101
qualify=yes

You’ll have to reference the entry between square brackets in your dialplan.
Hope it helps.

-Pietro.