Can't get Video to work with Linphone or Xlite

Hi there,

I hope someone can help me point out what I’m doing wrong here. I’m trying to get my Asterisk system to support video calls. The video works fine when I use two Jitsi clients to call each other. However, when I inspected with Wireshark, it appears that they are transmitting using UDP protocol. I need a client that transmit video files as RTP protocol for QoS purposes. I tried with Xlite and Linphone, but I couldnt get the video to work. I’ve been seeing the following warning in my Asterisk CLI:

*CLI> == Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Executing [2095@sunderland:1] Verbose(“SIP/5152053-00000010”, “someone is calling 2095”) in new stack
someone is calling 2095
– Executing [2095@sunderland:2] Dial(“SIP/5152053-00000010”, “SIP/5152095,40,tk”) in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Called SIP/5152095
– SIP/5152095-00000011 is ringing
[Apr 21 15:08:36] WARNING[2744]: chan_sip.c:9142 process_sdp: ignoring ‘video’ media offer because port number is zero – SIP/5152095-00000011 answered SIP/5152053-00000010

I have the following in my sip.conf:


And I’ve configured confbridge.conf to support video calls as well:

video_mode = follow_talker

No other configurations were done in asterisk concerning video calls. Am i missing something here?


I’m sorry for not being clear. I know that RTP is UDP - that isn’t what’s bothering me. In a bigger picture, I’m implementing QoS in my test network in the lab. The Cisco routers that I use has a function to recognise protocols automatically (using NBAR). Preferential treatments are given to protocols that are recognised as RTP. When clients like Xlite or Linphone are used, the network recognise these packets as real time packets, and preferential treatments are given accordingly. But it doesnt recognise Jitsi’s packets as real time packets – thus the reason why I need to get Xlite or Linphone to work.

Xlite and Linphone works fine for audio calls, but the video doesn’t work. Any suggestions to make video work in Xlite or Linphone? Can you see anything wrong with my config, or perhaps there is more to it that I don’t know?

Anything I can do about this warning?
[Apr 21 15:08:36] WARNING[2744]: chan_sip.c:9142 process_sdp: ignoring ‘video’ media offer because port number is zero

Dont bother, solved it - again :smile:

can you tell us how you solved it? i have the same problem.

That would be nice. Help out someone. eh?

If someone is getting error “Ignoring video stream offer because port number is zero”, the solution of the problem is install Xlite4.5. This error generated because the sip software is not opening the port for video calls.

I have check on Asterisk 11.3.0. I also getting the same error. :smiley:

I am facing the same “Ignoring video stream offer because port number is zero”. It seems that one endpoint sends “Media port 0” in SDP because does not understand the offered codecs, and thats the way to tell in the protocol.
The problem comes because althought both sides of the call supports H264, they offer it with different rtpmaps.
Then, in this case audio works but video does not.

My scenario:

Cisco 8941 - Call Manager 7.1.5 - SIP - Asterisk - XLite

Any help?

How can we fix it permanently ?