Can't get asterisk voicemail notification through email

Hello. i am new to asterisk. i have configured voicmail.conf and have included email addresses of the users. i am using RHEL5 linux. i removed sendmail as it seems difficult to configure. now i have installed postfix but i don’t know how to configure it. i want to received email notifications for voicemails. kindly guide me step up step for setting up postfix with asterisk.

Firstly, never use forum private mail to ask questions (this also appeared in my PM in box).

I’ve never heard of postfix.

My advice would be to delete it and install sendmail. Configuring sendmail should not be difficult, and, in my case, it actually worked without any configuration at all (although the office email system is particularly well configured in terms of MX records).

If you want to use it, use its support channels. Don’t expect step by step instructions, unless you are prepared to pay commercial support rates.

I also find sendmail to be a bit of overkill to set up if you only want to use it for sending e-mail notifications. That is why I set up a simple SMTP client called SSMTP. It is small, simple and very eazy to set up.

CentOS does not have it in it’s repositorys, so you have to check out Fedora/RHEL repositrys to get the RPM :wink:

thanks a lot. i will do check it out. thanks for the support.

hi. i configured ssmtp using the following links … and-ssmtp/

but when i try

sendmail and then type the message it doesnot get back by pressing CTRL-D. i have to release it using ctrl-c. the mail is also not sent.

kindly let me know how to configure it for asterisk voicmail email notification as well.

If this happened on sendmail itself, I’d assume you had a non-responding DNS server or mail relay (in the latter, particularly, an over-zealous fire wall might be involved) and you hadn’t waited for the attempt to time out and the mail to be queued for a later try.

I just wanted to add the link that I use to setup SSMTP … thost.html

it makes it real easy and works great!

For sending voicemail-to-email, did you try setting this parameter in voicemail.conf ?

mailcmd = /usr/sbin/ssmtp -t

no. i will try it. thanks.