Can't dial into SIP phone


#1

I have a SIP phone. Using X-Lite. The phone calls out just fine but I can’t call into the phone. Asterisk is outside the NAT. The Laptop/Xlite is on the inside of a NAT.

extensions.conf

exten => 4,1,Dial(SIP/mperkel)

sip.conf

[mperkel]
type=friend
secret=*****
nat=route
host=dynamic
canreinvite=no
disallow=all
allow=gsm ; GSM consumes far less bandwidth than ulaw
allow=ulaw
allow=alaw
regexten=3333
callerid=“Marc Perkel” <9876543210>

When I cal in and try to ring the SIP phone I get this:

-- Executing Dial("IAX2/exgn-2", "SIP/mperkel") in new stack

Jan 25 14:20:22 NOTICE[567]: app_dial.c:1011 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 3 - No route to destination)
== Everyone is busy/congested at this time (1:0/0/1)
== Auto fallthrough, channel ‘IAX2/exgn-2’ status is ‘CHANUNAVAIL’

Running Asterisk 1.2.3

Thanks in advance


#2

maybe try with
qualify = yes


#3

I’ll try that - what does qualify do?

Nope - didn’t work - I get exactly the same error - no route to destination.

Can anyone verify the syntax is at least correct? Should I be able to dial a SIP connection by:

Dial(SIP/mperkel) ?

Why does it think there is no route to destination?

Thanks in advance.


#4

means asterisk will ping this client
(not sure but someone here said not all IPphones like this )


#5

Didn’t seem to make a difference. I editited my last message above.


#6

Sure would be nice if I could get this working.


#7

Figured I’d post a response to this since a web search for this no route error message turned up your post. I’ve been using the Express Talk sip client and after reading your post I thought of and tried the following; temporarily disable XP firewall, added in a username= option for each of the sip entries which match the name used in brackets, specify the nat= statement explicitely even though the troublesome sip entry I was dealing with already matched the global one. I think thats about it. However after undoing the reverting the firewall exception it seemed to make no difference, so it may not have been that. If you narrow it down to anything more specific or have already solved it on your end please post again. Everything seems ok here at the time being though I have a feeling this issue will be revisited.

Too bad there aren’t NNTP news groups for this in addition to the web forum.


#8

so what’s providing the NAT interface ? can you add in some port-forwards to the phone for the ports you need ? (usually 5004, 5060 and whatever you have setup for RTP)