Cannot connect asterisk


#1

Cannot connect to Asterisk Manager with admin/amp111
This module requires access to the Asterisk Manager. Please ensure Asterisk is running and access to the manager is available.

I tried to run the amportal start, and I get error line 80 no directory.

Thanks


#2

Check to make sure that Asterisk is running, and that you have enabled the Manager Interface. The manager interface (manager.conf) is off by default.

Forgive me if this sounds overly simple, but you didn’t mention doing this already in your post.

Dan


#3

Manager Interface. The manager interface (manager.conf)

NO, i’m new to Linux. I have spent years on Mac’s and still love them, but I have been trying to get into linux.

How do I turn this on?

Thanks for the help!


#4

The Asterisk Manager Interface is configured with the file /etc/asterisk/manager.conf. There’s not much to the file. The general section is used to configure if it is turned on and what ip / port it runs on.

Other than that you just need to add users that are allowed to connect to it. The user name goes in brackets, and the password is specified by the secret tag. There are also permit and deny tags which can be used to specify what IP networks are allowed to connect. 99% of the time you only want to allow the manager interface on the localhost because all communication across the manager interface is insecure and in plain text. The last two tags are the read and write tags. These give your user the ability to perform certain tasks via the manager interface. The possibilities are system, call, log, verbose, command, agent, user, and all. I don’t recall what each gives permissions for but I’m sure you can find that on google or someone else can follow up with that.

example manager.conf
[general]
enabled=yes
port=5038 ; Make sure this TCP port is open on your firewall
bindaddr=127.0.0.1

[test]
secret=hackme
deny=0.0.0.0/0.0.0.0
permit=127.0.0.1/255.255.255.255
write=all
read=all

Good Luck,
Dan


#5

I got it working thanks for the info.