Can not dial out

I have a Grandstream budge Tone 100 connected to asterisk on the same network. The phone is not registered with asterisk, I beleive I don’t need to do that as asterisk and the phone are on the same network. The phone has dialtone.

In calling rules I have created a dialplan for the phone and assigned it to the phone. When I dial I don’t see anything happning on the CLI>
I was hopping to see something.

The phone should try to place a call though a service provider I have created for that dialplan.

Can some one help?

Asterisk version ? Dialplan ? I presume using SIP, so you would need to register.

narinder: how is the budgetone sending dtmf? If not currently by RFC2833 try that option.

AsteriskNow beta 4 32 bit x86, 32-bit processors.
Created a dialplan from the GUI. In GUI under that dial plan selected a service provider which I had created earlier.

I beleive you don’t need to register the SIP phones if they are on the same network as asterisk. My asterisk is on and the ohone on To get a dialtone on the phone I had to Uncheck the register box on the phone (I mean I uncheked register in the browser setup of the phone) then I got the dial tone. I was hopping some one can confirms if this is correct.

I did try setting dtmfmode=2833.

Since all this I just looked at the context in users.conf file for the phone which is numberplan-custom-1 and then in extensions.conf put in the dial string. exten => _X.,1,Dial(SIP/voiptalk/${EXTEN}) for this context manually.

Now I can connect a call but I don’t hear anything on either of the phones. Every one normally would say this is a NAT problem, But my asterisk and the sip phone is on the same network. Can’t think what could be the problem now.

Thanks colbec and uxbod

why would you think your phone doesn’t need to register with Asterisk ? and even if you were only using it as a proxy and not a registrar, what are you hoping to gain by not having a registration ?

I am not hoping to gain anything by not registering. Its only because I was getting error messages while phone was trying to register.

Also I think the reason you need to register the phone is Because when the phone and asterisk are different subnet there is no other way they can find each other without registering.

By registering asterisk and the phone knows where each other is. But if they are bot on the same subnet then even without registering they can find each other. Just like other network devices if they are on the same subnet. … erisk.html

In the debugging section of the above artical it reads:
If SIP registration seems to be the problem, you can try removing the secret= lines and specifying an IP address of the phone in the host= line. This will lock the phones onto specific addresses and remove any registration issues you might be having.

I think if you leave the secret line out then you need to leave the registeration out as well.

Please let me know if anyone thinks I am not correct in my understanding.

Sorry to repeat this but I may have misunderstood. By

did you mean that this is your setting in asterisk or in the budgetone?

In users.conf dtmfmode=2833 was not there for the phone.

Then I put in dtmfmode=2833 but the phone still did not work. When the phone eventually did work then I took dtmfmode=2833 out just to see if it would make any difference. It made no difference the phone was still working.

Like you said I think it should be there. I think may be it is there somewhere in general section of sip.conf. I believe as long as it is in sip.conf its ok.

I think users.conf must be included in sip.conf