Calls in queue but an available agent not getting the call

My asterisk version is asterisk-16.3-cert1. We’re using the asterisk queue application for ACD queues.

Our queues.conf is following:

[general]
persistentmembers=yes
autofill=yes                ; distribute all waiting callers to available members
monitor-type=MixMonitor     ; use the updated Mix-Monitor
shared_lastcall=yes         ; respect the wrapup time for members logged into more than one queue
log_membername_as_agent = yes

There are available agents in the queue and for some reason the calls are not being distrusted to them. There is a long delay(approximately 3 minutes before an agent gets the call) before the calls get sent to an agent.

Asterisk queue show displays the following information:

awh_ApptCH has 2 calls (max 5) in 'wrandom' strategy (143s holdtime, 172s talktime), W:0, C:397, A:53, SL:83.6%, SL2:82.4% within 180s
Members:
awh_cherry_ext1 (PJSIP/awh_cherry_ext1) (ringinuse disabled) (dynamic) (Not in use) has taken 2 calls (last was 66 secs ago)
awh_cherry_ext2 (PJSIP/awh_cherry_ext2) (ringinuse disabled) (dynamic) (in call) (In use) has taken 1 calls (last was 585 secs ago)
awh_cherry_ext3 (PJSIP/awh_cherry_ext3) (ringinuse disabled) (dynamic) (in call) (In use) has taken 1 calls (last was 367 secs ago)
Callers:
1. PJSIP/rt-00002bcd (wait: 2:36, prio: 0)
2. PJSIP/rt-00002bf1 (wait: 0:38, prio: 0)

You can see that there are two callers in the queue, and at least one agent is not in use. But, the call still stuck in the queue.

Then we tried to change the call distribution strategies from wrandom to rrmemory. But still, the same problem occurs.

awh_ApptCH has 1 calls (max 5) in 'rrmemory' strategy (81s holdtime, 162s talktime), W:0, C:6287, A:646, SL:85.8%, SL2:84.5% within 180s
Members:
awh_cherry_ext1 (PJSIP/awh_cherry_ext1) (ringinuse disabled) (dynamic) (paused:Personal Break was 459 secs ago) (Not in use) has taken 27 calls (last was 483 secs ago)
awh_cherry_ext2 (PJSIP/awh_cherry_ext2) (ringinuse disabled) (dynamic) (Not in use) has taken 52 calls (last was 178 secs ago)
awh_cherry_ext3 (PJSIP/awh_cherry_ext3) (ringinuse disabled) (dynamic) (in call) (In use) has taken 4 calls (last was 115 secs ago)
awh_cherry_ext4 (PJSIP/awh_cherry_ext4) (ringinuse disabled) (dynamic) (paused:Unspecified was 1015 secs ago) (In use) has taken no calls yet
Callers:
1. PJSIP/rt-000b2303 (wait: 3:05, prio: 0)

We have tried restarting the phones in the queue but no help. then, we also tried with member to unjoin
and then join the queue with no success.
The member shows not in use, but the call is still stuck in the queue.

The only pattern we were able to see so far is, if there is a caller(e.g caller1 ) on the queue connected to an agent( agent1 ) and another agent( agent2 ) is available, and a new call in queue comes( caller2 ), then it delays the call distribution( caller2 ). It seems once the first agent( agetn1 ) is off the phone and 2 agents( agent1 , agent2 ) are available the call then goes to the agent(based on the distribution strategy).

Any help or clue will be very much appreciated.

Thanks.

NB: On average, there are 3 to 5 active queues, with 2 to 6 agents available per queue.

Why are you using a cert version when you presumably don’t have a support contract?

Are there any announcement? Agents don’t actually pick calls, but rather calls pick agents, with some jiggery pokery to avoid queue jumping. If the top available call is playing an announcement, it won’t get answered. Also, even when not calls only check for agents once a second.

1 Like

We have a plan to have a support contract in near future, that’s why we used a cert version.

Yes, there is a long announcement. That’s the reason.

Thanks.