Calls getting dropped with PRI and asterisk


#1

I am using a PRI line configuired with asterisk

the call gets cut randomely after being able to have a conversation.Sometimes it gets disconnected in 10 secs and sometimes 120 seconds.what could be possible reason


#2

Post a log of the output of “pri intense debug span 1” and we can see which side disconnects and why.


#3

the log of intense pri debug

[ 02 01 01 41 ]

Supervisory frame:
SAPI: 00 C/R: 1 EA: 0
TEI: 000 EA: 1
Zero: 0 S: 0 01: 1 [ RR (receive ready) ]
N®: 032 P/F: 1
0 bytes of data
– Restarting T203 counter
– Restarting T203 counter
T203 counter expired, sending RR and scheduling T203 again
Sending Receiver Ready (32)

[ 00 01 01 41 ]

Supervisory frame:
SAPI: 00 C/R: 0 EA: 0
TEI: 000 EA: 1
Zero: 0 S: 0 01: 1 [ RR (receive ready) ]
N®: 032 P/F: 1
0 bytes of data
– Restarting T203 counter

< [ 00 01 01 41 ]

< Supervisory frame:
< SAPI: 00 C/R: 0 EA: 0
< TEI: 000 EA: 1
< Zero: 0 S: 0 01: 1 [ RR (receive ready) ]
< N®: 032 P/F: 1
< 0 bytes of data
– ACKing all packets from 31 to (but not including) 32
– Since there was nothing left, stopping T200 counter
– Stopping T203 counter since we got an ACK
– Nothing left, starting T203 counter
– Got RR response to our frame
– Restarting T203 counter

[ 00 01 40 40 08 02 80 87 45 08 02 81 90 ]

Informational frame:
SAPI: 00 C/R: 0 EA: 0
TEI: 000 EA: 1
N(S): 032 0: 0
N®: 032 P: 0
9 bytes of data
– Restarting T203 counter
Stopping T_203 timer
Starting T_200 timer
Protocol Discriminator: Q.931 (8) len=9
Call Ref: len= 2 (reference 135/0x87) (Terminator)
Message type: DISCONNECT (69)
[08 02 81 90]
Cause (len= 4) [ Ext: 1 Coding: CCITT (ITU) standard (0) 0: 0 Location: Private network serving the local user (1)
Ext: 1 Cause: Normal Clearing (16), class = Normal Event (1) ]
== Spawn extension (murtaza, 587, 5) exited non-zero on ‘Zap/20-1’
– Hungup ‘Zap/20-1’
– T200 counter expired, What to do…
– Retransmitting 13 bytes

[ 00 01 40 41 08 02 80 87 45 08 02 81 90 ]

Informational frame:
SAPI: 00 C/R: 0 EA: 0
TEI: 000 EA: 1
N(S): 032 0: 0
N®: 032 P: 1
9 bytes of data
– Rescheduling retransmission (1)

< [ 00 01 01 43 ]

< Supervisory frame:
< SAPI: 00 C/R: 0 EA: 0
< TEI: 000 EA: 1
< Zero: 0 S: 0 01: 1 [ RR (receive ready) ]
< N®: 033 P/F: 1
< 0 bytes of data
– ACKing all packets from 31 to (but not including) 33
– ACKing packet 32, new txqueue is -1 (-1 means empty)
– Since there was nothing left, stopping T200 counter
– Nothing left, starting T203 counter
– Got RR response to our frame
– Restarting T203 counter


#4

Well this is Asterisk disconnecting the call and it’s a normal disconnect. So it would appear that whatever phone you are using, it could be hanging up which then asterisk executes a normal hangup across the PRI.