Calls disconnect after 15 minutes


#1

Hi all,

I am using Asterisk 1.6.2.13 on Elastix 2.0.2. I am in the UK using Sipgate as my VoIP provider. All calls that proceed for 15 minutes are disconnected at the 15 minute milestone, incoming and outgoing. Looking at the Asterisk logs I see this:-
[Aug 4 09:45:37] VERBOSE[4347] pbx.c: – Executing [s@macro-dial:7] Dial(“SIP/sipgate_jonny-000000e5”, “SIP/202,15,tr”) in new stack
[Aug 4 09:45:37] VERBOSE[4347] netsock.c: == Using SIP RTP TOS bits 184
[Aug 4 09:45:37] VERBOSE[4347] netsock.c: == Using SIP RTP CoS mark 5
[Aug 4 09:45:37] VERBOSE[4347] app_dial.c: – Called 202
[Aug 4 09:45:37] VERBOSE[4347] app_dial.c: – SIP/202-000000e6 is ringing
[Aug 4 09:45:46] VERBOSE[4347] app_dial.c: – SIP/202-000000e6 answered SIP/sipgate_jonny-000000e5
[Aug 4 09:50:01] VERBOSE[2649] asterisk.c: – Remote UNIX connection
[Aug 4 09:50:01] VERBOSE[4365] asterisk.c: – Remote UNIX connection disconnected
[Aug 4 09:55:01] VERBOSE[2649] asterisk.c: – Remote UNIX connection
[Aug 4 09:55:01] VERBOSE[4374] asterisk.c: – Remote UNIX connection disconnected
[Aug 4 10:00:01] VERBOSE[2649] asterisk.c: – Remote UNIX connection
[Aug 4 10:00:01] VERBOSE[4384] asterisk.c: – Remote UNIX connection disconnected
[Aug 4 10:00:37] VERBOSE[2841] chan_sip.c: – Got SIP response 420 “Option Disabled” back from 217.10.79.23
[Aug 4 10:00:37] VERBOSE[4347] pbx.c: – Executing [h@macro-dial:1] Macro(“SIP/sipgate_jonny-000000e5”, “hangupcall”) in new stack
[Aug 4 10:00:37] VERBOSE[4347] pbx.c: – Executing [s@macro-hangupcall:1] GotoIf(“SIP/sipgate_jonny-000000e5”, “1?noautomon”) in new stack

The line that interests me most is "Got SIP response 420 “Option Disabled”. So, I found this bug report

issues.asterisk.org/view.php?id=17005

And this is where I get lost. From what I can tell Asterisk 1.6.2.13 includes this fix. Is this bug the same problem I am encountering? Also I have no session-timer settings in any of the configuration files as far as I can tell.

Any guidance would be appreciated. Thanks. Kevin


#2

Alltough You’re thinking, that You’ve got no session-timers settings in Your conf it seems to be related to this according to the default settings for this feature.

You may check the actual settings with asterisk -rx “sip show settings”. Session-Timers settings will appear in the section Global Signalling Settings: If the param Session Timers: is something other than Refuse add the following line to Your sip.conf in the [general]-chapter:

and the problem should disappear after a sip reload.


#3

I agree with abw1oim on the cause. His solution will work.

You may also check if there is a firewall that has closed port talking to port 5060 since call establishement, and reparameter so the session timer will be passed through, keeping the protection for lost sessions


#4

Thanks for the replies. I examined the sip settings and it was set to “accept”. So I amended the config file and did a sip reload. The sip settings now show “refuse”. I shall see if this sorts it. I am more confident in my firewall skills so lean more towards an Asterisk issue, which hopefully is now resolved.

Thanks again.