Calling Asterisk on a Synology SIP error 401

I have Installed Asterisk on Synology.
After configuring Asterisk on Synology wiht Voipstunt and Internetcalls, i am able to make calls internally and externally.
When I want to call back the number with another VoIP device that works, I get an error:
“De gesprekspartner heeft het gesprek beeindigd met een SIP error 401” Dutch
"The caller has ended the call with a SIP error 401"

What can I do to get working?

I’m assuming the Synology part of this is not relevant.

401 is not an error. It is the mechanism by which a SIP server tells a SIP client how to send its password. Asterisk uses the basic SIP authentication mechanism, so either the SIP client doesn’t support authentication at all, or has not had a password set.

It’s not entirely clear what sort of call is failing, but if this is an incoming call from an ITSP, most ITSPs don’t support authenticating themselves to customer systems. If you need to authenticate to the ITSP, you can get round this on recent systems by using remotesecret, rather than secret, and on older systems by using insecure=invite, along with a secret.

I use the following version:
Asterisk Build:
Asterisk/1.8.13.1
Asterisk GUI-version : 2.1.0-rc1


AsteriskGUI is end of life. Synology seem to be supplying it on new systems, so they should support it.

I think remotesecret is newer than 1.8, so you will probably need to set insecure=invite. I imagine that is done using the “insecure” pulldown.

It still does not work!
Can anyone please help me with this problem :question: :cry:

Synology should provide the support, as they are supplying the otherwise unsupported software.

If you have actually got insecure=invite set in sip.conf, now, you should look to see if you actually have sip.conf entry that matches the ITSP at all. You may be getting a faked 401 to confuse hackers.

There is not very much in my sip.conf

I meant look at the actual file, and all the files it includes. With GUIs the information may also be in users.conf…

It is unlikely that you will get this debugged in AsteriskGUI terms, here, as AsteriskGUI is basically only used by Synology.

For a newcomer I am learning it quickly (I hope)
This is the setting

User_1

fullname=6003
registersip=no
host=dynamic
callgroup=1
mailbox=6003
call-limit=100
type=peer
username=6003
transfer=yes
callcounter=yes
context=DLPN_Internetcalls1
cid_number=6003
hasvoicemail=yes
vmsecret=@@@@
email=
threewaycalling=no
hasdirectory=no
callwaiting=no
hasmanager=no
hasagent=no
hassip=yes
hasiax=yes
secret=@@@@@3
nat=yes
canreinvite=no
dtmfmode=rfc2833
insecure=no
pickupgroup=1
macaddress=@@:@@:@@:@@:@@:@@
autoprov=yes
label=6003
linenumber=3
LINEKEYS=1
requirecalltoken=auto
disallow=all
allow=ulaw,gsm

trunk_1

host=sip.internetcalls.com
username=@@@@@@@@@@
secret=@@@@@@@@@
trunkname=Internetcalls
context=DID_trunk_1
hasexten=no
hasiax=no
hassip=yes
registeriax=no
registersip=yes
trunkstyle=voip
disallow=all
allow=all

You haven’t succeeded in setting insecure.