Caller shown as anonymous or itself

We have been programming a asterisk application that includes angular 4 interface and functions with asterisk api. We solved many problems yet there is something that we couldn’t figure out. The problem is this; When a caller calls another phone it shows the callerid as anonymous. This wasn’t a problem until we coded a webrtc sip. When a sip calls another sip using webrtc video call, caller sees his webcam output and input on same screen yet called side cannot see anything because on webrtc calls caller id appears as their id so webrtc thinks caller called himself and shows his own webcam. We have tried all of the webrtc sips on the internet so it is not caused by them. We are using pjsip, not the regular sip. There are lot of config datas so i can’t post them here one by one. If you think this problem caused by configs, just ask me to post the faulty config. We are desperate on this problem so any help is appreciated.

Which version of Asterisk are you using?
Yes, please post at least the endpoint configuration for both endpoints.

Asterisk version : 15.1.4

We are using pjsip and mongodb for sip configuration.


    'type': 'auth',
    'username': '1000',
    'password': 'asterisk'


    'type': 'aor',
    'support_path': 'yes',
    'remove_existing': 'yes',
    'max_contacts': '1'

Endpoint :

    'type': 'endpoint',
    'fromuser': '1000',
    'username': '1000',
    'disallow': 'all',
    'allow': 'g722,ulaw,alaw,vp8,opus,h264',
    'ice_support': 'yes' ,
    'force_rport': 'yes' ,
    'rewrite_contact': 'yes',
    'rtp_symmetric': 'yes',
    'context': 'default',
    'auth': '1000',
    'aors': '1000',
    'use_avpf': 'yes',
    'media_encryption': 'dtls',
    'dtls_ca_file': '/etc/asterisk/keys/ca.crt',
    'dtls_cert_file': '/etc/asterisk/keys/asterisk.pem',
    'dtls_verify': 'fingerprint',
    'dtls_setup': 'actpass',
    'media_use_received_transport': 'yes',
    'rtcp_mux': 'yes',
    'insecure': 'port,invite',
    'tos_video': 'af41',
    'cos_video': '4',
    'sendrpid': 'yes',
    'trustrpid': 'yes',
    'direct_rtp_setup': 'no',
    'webrtc': 'yes',
    'dtmf_mode': 'rfc4733',
    'host': 'dynamic', 
    'secret': 'asterisk',
    'connected_line_method': 'invite',
    'qualify': 'yes',
    'nat': 'yes',

You have a mix of chan_sip and chan_pjsip parameters in your endpoint definition. I’d suggest straightening them out and trying again. You can do a "pjsip show endpoint " to see what’s currently in effect. Specific to your issue, “sendrpid” and “trustrpid” aren’t valid endpoint parameters.

Those chan_sip parameters added because of desperation :slight_smile:. Could you please give endpoint parameters for our subject?

1 Like

We found out that problem wasn’t caused by endpoint configurations. It is caused by rest api. We are using a dial-bridge api of asterisk. I tried to search for any possible example to initiate video call on api but search was vain. So i need a solution for api not the configurations.