Call Recording sounds under water... sometimes

So the deal is:

  • It’s a PBX box then a Billing box then the upstream provider.
  • The entire system is g729 based, so it pass-through all the way.
  • The call quality is perfect, not even the smallest problem with the actual call.
  • However the call recording is choppy and sounds like its under water… some times, and only on one channel - the channel between us and the ISP. (We are in the same building).

Also note worthy:

  • The call records as WAV(GSM). (Since a g729 recorded call is a bout the most useless thing)
  • Yesterday the g729 payload from my isp was set to :60, now its set to :20, this cleared up “some” of the calls. (however the majority are still bad).
  • This only became a problem when the billing box (this box does not do any recording at all) was upgraded from Asterisk 1.4 to 1.8 (Actually is was an entirely new machine)
  • The PBX box is a dual quad core Xeon 2.8, with 16Gigs of RAM - it normally runs at 0.00000% usage and an average load of 0.0… ok not really - but pretty close… ITS NOT THE BOX.
  • There is a 8GIG RAM drive made from the 16GIG’s system memory, mapped to the call recordings folder… so its not the disk.

There is something strange about the way the calls are recorded (sometimes) and only on one channel (using mixmonitor).

Does anyone have any idea about what I could look at to fix this?

Tricky one hey?

OK, so after a bit of digging around and asking other people this “libresample” library came up. I installed it, and re-complied Asterisk with it, but this had no effect.

I still think the problem lies in the payload settings, because “some” calls are 100% (both channels), so the question is why are the others not? Now, when we got our ISP to change the payload from :60 ms to :20ms, it then cleared it up for “some” otherwise all the call (recordings) where bad.

My thinking is that this may be a payload mismatch that asterisk is allowing, but I want to force the payload to be the same globally, and fix to a value not “default”… where / how do I do this?

We resolved the problem, thanks for all the input.

And how did you solve it?
We couldn’t help you, but you can help others by posting your solution.