Call from '' (From empty)

Hello team,

Please, if any member of the group can support me, I have an asterisk which was working without any problem but I have decided to update it from the Asterisk certified/11.6-cert18 version to the Asterisk certified/13.21-cert6 version, finding the following situation:

At the moment of receiving calls from an SBC to the asterisk plant, these remain with the empty from, therefore, it looks for the default context which does not exist returning this way a 404 to the SBC. Now, if I do the test from a softphone call xlite, zoiper, 3cx is connected without news.

Error log relationship

chan_sip.c: Call from ‘’ (107.86.21.14:51383) to extension ‘1111’ rejected because extension not found in context ‘default’.

Trunk Script

[trunk-inbound]
host=107.86.21.14
dtmfmode=rfc2833
type=peer
port=5060
transport=tcp
disallow=all
allow=g729
allow=alaw
allow=ulaw
insecure=port,invite
context=centraldid
qualify=yes
nat=yes

It should be noted that this same configuration worked correctly with asterisk version 11.

I appreciate the comments or observations.

Greetings.

Translated with www.DeepL.com/Translator (free version)

The call isn’t matching against the section you have provided. We need to see the section it is matching. Do you have another section with the same host value? Although it seems common to have both inbound and outbound sections for the same peer, I’ve yet to find a case where they are needed, and which one will actually get used for inbound calls is not specified.

I don’t think you are matching as guest, but without your general section, we can’t confirm that allowguest is disabled.
Also, you are using cert versions, but you are using chan_sip, which is not supported by Sangoma’s commercial support (and not loaded, by default, in certified versions). The only reason for using certified versions is if you are using paid support from Sangoma, but Sangoma would not support you, because you are using chan_sip. Anyone using community support should use the latest fully release (not rc) minor version.

You have the deprecated “yes” setting for nat, but no sign of anything setting the external address, which is the real requirement for NAT, and will automatically result in force_rport and comedia being set, when nat= is left to default and the address is not local.

Your call came to default dialplan, since you have allow_guest=yes, and the origination peer did not match the peer definition for some reasons. Make sure that you still hvae chan_sip running on 5060 after upgrade.

Also, try to comment these lines:

port=5060
transport=tcp

then do
rasterisk -rx ‘sip reload’
and try again.