Call forwarding does not work

Hi All,

I tried to set CF (unconditional) but without any luck.
exten => CFU,1,DBput(CFIM/${CALLERIDNUM}=VoiceMailSystem)
exten => CFU,2,Hangup
exten => CF,1,Set(DB(CFIM/${CALLERID(NUM)})=VoiceMailSystem)
exten => CF,2,Hangup

(VoiceMailSystem is a user in my Asterisk)

when calling CFU the console shows:
– Executing DBput(“SIP/6891-081a9ec0”, “CFIM/6891=VoiceMailSystem”) in new stack
– DBput: family=CFIM, key=6891, value=VoiceMailSystem
– Executing Hangup(“SIP/6891-081a9ec0”, “”) in new stack
== Spawn extension (internal, CFU, 2) exited non-zero on ‘SIP/6891-081a9ec0’

when calling CF the console shows:
– Executing Set(“SIP/6891-0819e288”, “DB(CFIM/6891)=VoiceMailSystem”) in new stack
– Executing Hangup(“SIP/6891-0819e288”, “”) in new stack
== Spawn extension (internal, CF, 2) exited non-zero on ‘SIP/6891-0819e288’

X-Lite in both cases shows 603 Declined.

When I try to call the extension to which CFU should be active I still get a ringing tone at this extension.

Any idea?

hi all. i got a similar problem but with asterisk

in extensions.conf

exten => _921X.,n,Set(DB(CFU/${CALLERID(num)})=${EXTEN:3}) exten => _921X.,n,Set(DB(CFUC/${CALLERID(num)})=${CONTEXT})

in CLI after forwarding to number 25

    -- Executing [92125@DLPN_default:5] Set("SIP/16-081c3ac0", "DB(CFU/16)=25") in new stack
    -- Executing [92125@DLPN_default:6] Set("SIP/16-081c3ac0", "DB(CFUC/16)=DLPN_default") in new stack
voipcom10*CLI> database show
/CFU/16                                           : 25
/CFUC/16                                          : DLPN_default

everything seems to be working fine but when i call the number it simply keeps ringing instead of being redirected to number 25 as I would expect from a “call forward unconditional”

any ideas?