'Call Failed: 404 Not Found'


#1

Hi,

I just setup xten’s X_Lite SIP phone. I can login with asterisk without
a problem, and I can answer incoming calls. But when I try to dial out I
get a error ‘Call failed: 404 Not Found’.

[incoming]
exten=> 11,1,Dial(SIP/danny)
exten=> 12,1,Dial(SIP/shirley)

[danny]
;Turn off silence suppression in X-Lite (“Transmit Silence”=YES)!
;Note that Xlite sends NAT keep-alive packets, so qualify=yes is not needed
type=friend
regexten=11 ; When they register, create extension 1234
username=danny
secret=*****
callerid=“danny yang” <5678>
host=dynamic
nat=yes ; X-Lite is behind a NAT router
canreinvite=no ; Typically set to NO if behind NAT
;disallow=all
allow=gsm ; GSM consumes far less bandwidth than ulaw
allow=ulaw
allow=alaw

[shirley]
;Turn off silence suppression in X-Lite (“Transmit Silence”=YES)!
;Note that Xlite sends NAT keep-alive packets, so qualify=yes is not needed
type=friend
regexten=12 ; When they register, create extension 1234
username=shirley
secret=*****
callerid=“Shirley Yu” <5678>
host=dynamic
nat=yes ; X-Lite is behind a NAT router
canreinvite=no ; Typically set to NO if behind NAT
;disallow=all
allow=gsm ; GSM consumes far less bandwidth than ulaw
allow=ulaw
allow=alaw


#2

Hi,

You have to manage the context in your sip.conf for both sip softphones.

So, you have to add in sip.conf the following line for users both users danny and shirley:

context=incoming

It have to be the same context name as the one used in extensions.conf

You can add this at the end of user declaration.

Regards,
Mircea.