Busy tone received with delay

Dear Asterisk Community,

I have been struggling with an issue for about 2 weeks now, I tried allot of settings buts until now I still don’t know what is wrong.

When 2 users call each other and a third user (USER_3 in the logs) tries to call user 2 (USER_2 in the logs), he doesn’t immediately get the busy tone and the connection is not directly ended.

We are using SSL and what I seem to be able to read from the logs is that the RTP connection between USER_2 and USER_3 is destroyed immediately but the SIP channel isn’t destroyed immediately and delays up to around 10 seconds…

We had this running in the past without SSL and the busy tone was given within a second.

Here you will find the logs here:

The long delay is from [2019-09-30 19:00:52] to [2019-09-30 19:01:02], I put some blocks in the logs with the word “INTERESTING”, where I thought that that could interesting.
And I also noted where I think the USER_2 disconnected and USER_3.

Best regards,
x

I think we need the contents of the the from_user context, and the from_sip contexts, but user agent suggests that they are provided by FreePBX, and this is the wrong forum for FreePBX dialplan issues.

The delay is because it thinks that an incomplete number has been dialed.

I’d be a bit surprised if it worked that way, but it is possible that there is a specific match for earlier priorities in from_user, but the next priority has a couple of matching patterns.