Bad IP Address in Connection information

Hi,

I have an Asterisk server NATed and some SIP Speakers are connecting to the PBX.

When I initiate a call, the RTP packets are sending over to the local IP address of the SIP Speaker.

Here’s the malformed packet:

Frame 4: 886 bytes on wire (7088 bits), 886 bytes captured (7088 bits)
Ethernet II, Src: Fortinet_84:aa:d0 (08:5b:0e:84:aa:d0), Dst: VMware_7e:11:4d (00:0c:29:7e:11:4d)
Internet Protocol Version 4, Src: 204.101.58.123, Dst: 172.29.9.94
User Datagram Protocol, Src Port: 3212, Dst Port: 5060
Session Initiation Protocol (200)
Status-Line: SIP/2.0 200 OK
Message Header
Via: SIP/2.0/UDP 66.158.139.50:5060;rport=5060;received=66.158.139.50;branch=z9hG4bK0675f91f
Call-ID: 218acd6227a6a2c55cd2fd056e63b606@66.158.139.50:5060
[Generated Call-ID: 218acd6227a6a2c55cd2fd056e63b606@66.158.139.50:5060]
From: “Simon-Phone” sip:207@66.158.139.50;tag=as25910f6b
To: sip:370@204.101.58.123;ob;tag=so2xX6QZL9M30CuZSENAjMR5UPkhrEGT
CSeq: 102 INVITE
Contact: sip:370@204.101.58.123:3212;ob
Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, INFO, SUBSCRIBE, NOTIFY, REFER, MESSAGE, OPTIONS
Supported: replaces, 100rel, timer, norefersub
Content-Type: application/sdp
Content-Length: 279
Message Body
Session Description Protocol
Session Description Protocol Version (v): 0
Owner/Creator, Session Id (o): - 3790112006 3790112007 IN IP4 192.168.44.64
Session Name (s): pjmedia
Bandwidth Information (b): AS:699
Time Description, active time (t): 0 0
Session Attribute (a): X-nat:0
Media Description, name and address (m): audio 4026 RTP/AVP 0 101
Connection Information ©: IN IP4 192.168.44.64
Bandwidth Information (b): TIAS:650000
Media Attribute (a): rtcp:4027 IN IP4 192.168.44.64
Media Attribute (a): sendrecv
Media Attribute (a): rtpmap:0 PCMU/8000
Media Attribute (a): rtpmap:101 telephone-event/8000
Media Attribute (a): fmtp:101 0-16
[Generated Call-ID: 218acd6227a6a2c55cd2fd056e63b606@66.158.139.50:5060]

The address in the message body is wrong but “To:” in the header is the right address.

We have like 30 SIP Speakers connected to the PBX and it was working fine before.

Thanks for any response.

chan_sip or pjsip channel driver ?

I tried both but still the same issue.

Show sip settings for endpoint configuration

Here is the extension configuration

[370]
deny=0.0.0.0/0.0.0.0
disallow=all
secret=6755f8f28a90d33bebee031ca46162c7
dtmfmode=rfc2833
canreinvite=no
context=from-internal
host=dynamic
defaultuser=
trustrpid=no
sendrpid=no
type=peer
session-timers=accept
nat=force_rport,comedia
port=5060
qualify=yes
qualifyfreq=60
transport=udp
avpf=no
force_avp=no
encryption=no
namedcallgroup=
namedpickupgroup=
allow=alaw;ulaw
dial=SIP/370
accountcode=
permit=0.0.0.0/0.0.0.0
callerid=Ford Lincoln 440 <370>
callcounter=yes
faxdetect=no

And the SIP show peer

  • Name : 370
    Description :
    Secret :
    MD5Secret :
    Remote Secret:
    Context : from-internal
    Record On feature : automon
    Record Off feature : automon
    Subscr.Cont. :
    Language : en
    Tonezone :
    AMA flags : Unknown
    Transfer mode: open
    CallingPres : Presentation Allowed, Not Screened
    Callgroup :
    Pickupgroup :
    Named Callgr :
    Nam. Pickupgr:
    MOH Suggest :
    Mailbox :
    VM Extension : *97
    LastMsgsSent : 32767/65535
    Call limit : 2147483647
    Max forwards : 0
    Dynamic : Yes
    Callerid : “Ford Lincoln 440” <370>
    MaxCallBR : 384 kbps
    Expire : 105
    Insecure : no
    Force rport : Yes
    Symmetric RTP: Yes
    ACL : Yes
    DirectMedACL : No
    T.38 support : No
    T.38 EC mode : Unknown
    T.38 MaxDtgrm: 4294967295
    DirectMedia : No
    PromiscRedir : No
    User=Phone : No
    Video Support: No
    Text Support : No
    Ign SDP ver : No
    Trust RPID : No
    Send RPID : No
    TrustIDOutbnd: Legacy
    Subscriptions: Yes
    Overlap dial : Yes
    DTMFmode : rfc2833
    Timer T1 : 500
    Timer B : 32000
    ToHost :
    Addr->IP : 204.101.58.123:3235
    Defaddr->IP : (null)
    Prim.Transp. : UDP
    Allowed.Trsp : UDP
    Def. Username: 370
    SIP Options : (none)
    Codecs : (alaw)
    Codec Order : (alaw:20)
    Auto-Framing : No
    Status : OK (8 ms)
    Useragent : AXIS C3003-E Network Horn Speaker
    Reg. Contact : sip:370@204.101.58.123:3235;ob
    Qualify Freq : 60000 ms
    Keepalive : 60000 ms
    Sess-Timers : Accept
    Sess-Refresh : uas
    Sess-Expires : 1800 secs
    Min-Sess : 90 secs
    RTP Engine : asterisk
    Parkinglot :
    Use Reason : No
    Encryption : No

add to the general section the following parameters localnet , media_addr and extern_addr

That have been done but no chance.

If this is part of the local net add it also to the SIP configuraton

This is the local address of the SIP Speaker.

This one is supposed to be connecting to our public IP addess but the connection information is not translated and traffic is being sent to the local IP address instead of the public IP address as it supposed to.

Check router setting and device SIP setting, mybe you re missing a NAT configuration on the device