Authentification problem. wrong password

Hello to you. I have a problem with my softphone. I have created sip account already, but when I try to connect my softphone, I have this message on the server: Chan_sip.c:28382 handle_request_register:registration from ‘"alicesip:6001@’ failed for ‘’ -Wrong Password.
I have verified all, it’s matched but I have the message. What can I do please??

Can you send your sip.conf detail?


If i recall permit should be first, give it a try.

It didn’t work, I’ve tried but the same error message came

Permit should not be first.

Generally, if it says wrong password, it means wrong password. However, you should check it is matching the correct sip.conf entry.

I’ve tried to change the password and now when I want to reload de sip, I get this message:
Phone_message.c:1645 build_dialplan_routing: Unable to build dialplan routing - invalid license.

That’s related to the phone. If you got the message from Asterisk, you are almost certainly trying to use a feature that is not appropriate for your phone.

That message is from the DPMA module for Digium phones. It means that your license is invalid for some reason.

Ok. Thank you, i’ll try another phone

How can i fix it please?

If you use the Asterisk CLI command “digium_phones license status” you will probably see the response “No valid product license”. This means that either the DPMA license was not successfully registered, or the current license file for some reason is no longer valid (for example, if the ethernet card was changed)… To correct this, either repeat the register process with the same license code, or obtain a new one.

This shows how to register the license code:

You can get a new license code here for free:

Thanks @sgriepentrog … It Works!!