Audio delay of 1-2s in stasis app (ARI)

Hi,
I am using ARI.
Procedure:

  1. Originate to client 1(channel 1) outside Stasis (app => nameApp).
    If client answer:
  2. Create a bridge ( 'type' => 'mixing')
  3. Ring to channel 1
  4. Create channel 2 (client 2)
  5. Add both channels to the bridge
  6. Dial to channel 2
    If client 2 answer - start recording bridge (format ogg)

Both clients use mobile phones. The asterisk serves as a connector for clients. The endpoint for both calls is the same trunk.

But when the second client answers the call and traffic is being transmitted, a voice delay of 1-2 seconds is noticed.
If you call outside of Stasis, then there will be no voice delay. Help me find the reason please. Sorry for the bad translation.
Asterisk.txt (666.9 KB)

From what I can tell media is forwarding as soon as it is received. Have you done a packet capture to actually look at what is being received and sent?

How should I do it? Thanks

tcpdump or wireshark (I think most people use tcpdump on Linux and run wireshark on the result on Windows, but wireshark can be installed on Linux, if you have X, although generally it is a bad idea to run X on a real time system, like Asterisk.

People also seem to use sngrep, which appears to come with standard FreePBX installations, so is often used by FreePBX users. However, I haven’t used it myself, so cannot say whether it is the right tool here.

More generally though, you may need to make captures at other points in the network, and that will depend on the capabilities of the various network components. It is, however, something that any network administrator needs to learn.

thanks

attach file
aster.txt (1.9 MB)

If you’re using VoIP, you should learn how to analyze this yourself. In wireshark if you open a capture you can listen to the audio and see if there actually is a delay introduced by Asterisk.

We do not use VoIP. But why is there no delay in the dialplan, but in stasis there is a delay of 1-2 seconds? The configurations are applied to all parameters.

Do I need to enable dtmf on the bridge when calling two mobile phones?

You’re using PJSIP channels. That’s VoIP. I don’t know why you’ve brought up DTMF. You can enable it if you want.

Did you check the audio in the packet capture to see if the audio FROM Asterisk is actually delayed?