asterisk120-beta1 transfer call no ring tone generated


#1

This worked for me in earlier versions, prior to 1.2.0-beta1. When I transfer an incoming caller to another number or extension, the caller does not hear any ringing. I have tried to generate the ringing use the r feature from the dial command with no luck. If I specify m instead of r, the caller hears the onhold music.

I’ve tried several combinations, but nothing seems to work.

Any thoughts on how I can get this issue resolved?

Thank you in advance!


#2

I forgot to mention that I am using Cisco 7960 phones with asterisk. When I specify the transfer soft-key on the Cisco phone, no ringtone is generated. When I use the BlindXfer soft-key, the ringtone is generated!


#3

I tried downgrading my Cisco phones to an earlier SIP image from cisco, thinking that might be the problem. Not it. Currentling running SIP 7.5.

I noticed when I use the transfer feature, a ZOMBIE appears on the channel, and the caller doesn’t get the ring. When using blind transfer, no zombie, and the ring appears!

Anybody have any ideas how I can resolve this? Here’s the console output.

-- Accepting call from '2532612594' to '2180650' on channel 0/1, span 1
-- Executing Dial("Zap/1-1", "SIP/120|20|t") in new stack
-- Called 120
-- SIP/120-ccab is ringing
-- SIP/120-ccab answered Zap/1-1
-- Started music on hold, class 'default', on channel 'Zap/1-1'
-- Executing NoOp("SIP/120-841d", "") in new stack
-- Executing Goto("SIP/120-841d", "intern-post|500|1") in new stack
-- Goto (intern-post,500,1)
-- Executing Dial("SIP/120-841d", "SIP/500|20|tr") in new stack
-- Called 500
-- SIP/500-bdae is ringing
-- Stopped music on hold on Zap/1-1

== Spawn extension (local, 2180650, 1) exited non-zero on ‘SIP/120-841d’
– Channel 0/1, span 1 got hangup request
== Spawn extension (intern-post, 500, 1) exited non-zero on ‘Zap/1-1’
– Executing Hangup(“Zap/1-1”, “”) in new stack
== Spawn extension (intern-post, h, 1) exited non-zero on ‘Zap/1-1’
– Hungup ‘Zap/1-1’