Asterisk1.4.22 + uw-imap2007e ,Imap with SSL not working

I am using asterisk 1.4.22 with c-client 2007e (built with SSL) . I am trying to test the voicemail storage over SSL with a dovecot installation and even Gmail server ( , port 993) .
My setup works with dovecot over port 143 using TLS . But when I switch to 993 port, I get connection timeouts messages. I can verify the port 993 is open with DOvecot running with imaps enabled. I get the following messages:

*CLI> [Feb 27 16:53:27] ERROR[31875]: app_voicemail.c:1713 mm_log: IMAP Error: Connection failed to,993: Connection timed out
[Feb 27 16:53:27] ERROR[31875]: app_voicemail.c:1488 init_mailstream: Can’t connect to imap server {}Voicemail
[Feb 27 16:53:27] ERROR[31875]: app_voicemail.c:1201 messagecount: IMAP mailstream is NULL

I tried to test the same setup with (port 993) in case my dovecot setup was wrong. But I get same message there.

My voicemail.conf configuration is following:

I did some packet capture . I see asterisk does the TCP handshake is this case but after that no packet exchange happens and then after some time asterisk closes the connection.

I would appreciate any help if this is some bug with c-client lib or some configuration issue…


the solution was easier :smile: … just need ‘ssl’ flag to be passed in voicemail imap configuration.
Atleast its working with gmail now . I see the asterisk is still not able to fetch voice messages from the gmail folders and asterisk crashes often too.