Asterisk with snom and sipcall.ch

Hello,
My english is bad i know.

I have a problem with Asterisk on the Raspberry pi with raspbian.

Following error code will be show when i call out of my system.

[Jun 27 13:50:41] ERROR[2017]: chan_sip.c:29650 setup_srtp: No SRTP module loaded, can’t setup SRTP session.
[Jun 27 13:50:41] NOTICE[2017]: chan_sip.c:22753 handle_request_invite: Call from ‘41446134598’ (192.123.221:2066) to extension ‘0792221701’ rejected because extension not found in context ‘meine-telefone’.
[Jun 27 13:51:19] NOTICE[2017]: chan_sip.c:22753 handle_request_invite: Call from ‘’ (212.117.203.36:5060) to extension ‘41446134598’ rejected because extension not found in context ‘default’.

now i have set
sip.conf

[general]
; sipcall.ch needs a useragent different from asterisk
useragent=portasipfriendly
register =>41445112398:unvf9jys@sip.backbone.ch/41445112398
port=5060
encryption=no

[41445112398]
type=friend
context=meine-telefone
secret=1234
host=dynamic
mailbox=2000
nat=yes

extension.conf

[sonstige]

[meine-telefone]
exten => 41445112398,1,Dial(SIP/{EXTEN},20,j) exten => 41445112398,2,VoiceMail(u{EXTEN})
exten => 41445112398,3,VoiceMailMain(s${CALLERID(num)})
exten => 41445112398,4,VoicemailMain(s${CALLERID(num)})

modules.config:

; Asterisk configuration file
;
; Module Loader configuration file
;

[modules]
autoload=yes
noload=res_srtp.so
; Any modules that need to be loaded before the Asterisk core has been
; initialized (just after the logger has been initialized) can be loaded
; using ‘preload’. This will frequently be needed if you wish to map all
; module configuration files into Realtime storage, since the Realtime
; driver will need to be loaded before the modules using those configuration
; files are initialized.
;
; An example of loading ODBC support would be:
;preload => res_odbc.so
;preload => res_config_odbc.so
;
; If you want, load the GTK console right away.
; Don’t load the KDE console since
; it’s not as sophisticated right now.
;
noload => pbx_gtkconsole.so
;load => pbx_gtkconsole.so
noload => pbx_kdeconsole.so
;
; Intercom application is obsoleted by
; chan_oss. Don’t load it.
;
noload => app_intercom.so
;
; The ‘modem’ channel driver and its subdrivers are
; obsolete, don’t load them.
;
noload => chan_modem.so
noload => chan_modem_aopen.so
noload => chan_modem_bestdata.so
noload => chan_modem_i4l.so
;
; Comment this out (after installing CAPI middleware and hardware
; drivers) if you have CAPI-able hardware and wish to use it in
; Asterisk.
;
noload => chan_capi.so
;
load => res_musiconhold.so
;
; Load either OSS or ALSA, not both
; By default, load OSS only (automatically) and do not load ALSA
;
noload => chan_alsa.so
;noload => chan_oss.so
;
; Disable CDR logging to SQLite by default since it writes unconditionally to
; cdr.db without a way to rotate it.
;
noload => cdr_sqlite.so
;
; These conflict with app_directory.so and each other.
noload => app_directory_odbc.so
;
; Enable these if you want to configure Asterisk in a database
;
noload => res_config_odbc.so
noload => res_config_pgsql.so
;
; Module names listed in “global” section will have symbols globally
; exported to modules loaded after them.
;
[global]

sip show peers:
Name/username Host Dyn Forcerport ACL Port Status
41441237598/41441237598 192.168.61.21 D N 2066 Unmonitored
1 sip peers [Monitored: 0 online, 0 offline Unmonitored: 1 online, 0 offline]

sip show registry:
Host dnsmgr Username Refresh State Reg.Time
sip.backbone.ch:5060 N 41441231598 105 Registered Fri, 27 Jun 2014 14:03:33
1 SIP registrations.

All numbers and ips are changet

pic is the configuration of firewall

noload=res_srtp.so

what is with: noload=res_srtp.so?

It is stopping you loading SRTP support.

I changed this setting but nothing go.
i cant call out and no call come in.
When i call the number the asterisk know that a phone is coming but the phone is not ringing :s