Asterisk with polycome IP 301/501 phone--DTMF issue


#1

Hi ,

i use ASterisk 1.2.4 with polycome IP 301/501 IP phones. it works great , buy only thing is it is not taking the DTMF dgits. below i am pasting the sip.conf and extensions.conf and also polycom sip.cfg file.

sip.conf

[290]
type=friend
secret=blah
host=dynamic
qualify=yes
nat=yes
disallow=all
;allow=ulaw
allow=g729
context=epo
dtmfmode=info
canreinvite=yes
insecure=invite
mailbox=290@voicemail

extensions.conf

exten => 290,1,Dial(SIP/290,60,rtT)
exten => 290,2,voiceMail(290@voicemail)
exten => 290,3,PlayBack(vm-goodbye)
exten => 290,4,Hangup()

and sip.cfg for polycom firmware

i shall be thankfull if any one can give your valuable suggestions to fix the issues.

i have voicemail configured in extensons.conf to 850

when i dial , it take me to voicemail login and after the enter the user and passwrod, it says incorrect login…
in the cli prompt. it prints… vm-authenticate:couldn’t read username.


#2

in sip.conf:

dtmfmode=rfc2833

in sip.cfg

I suspect simply changing sip.conf will do it.

p


#3

yup, dtmfmode needs to be rfc2833, and we did not have to change the sip.cfg polycom config files.


#4

Hi,

i changed the same in sip.conf and reloaded the asterisk … still i face the DTMF issue.

Please help me!


#5

what version of the polycom firmware are you running? you should be able to get this from the settings menu - there is a status entry on my phone.

FYI, we’re running the 2.6.2 bootrom, and SIP 1.5.2. the polycom app version is 1.1.3.

also, you might check out this page: voip-info.org/wiki-Polycom+Phones - there are specific notes for each model, as well as firmware/bootrom version notes. be careful updating the bootrom past 2.6.x, as you cannot downgrade after that point…