Asterisk Virgin needs help - NAT extension to NAT Asterisk


Thanks in advance.

I have this setup.

SIP Softphone behind a NAT ( X300 ) in Montery
Asterisk servier behind a NAT in San Jose

SIP Softphone ( X202 ) behind NAT on same net
as Asterisk Server.
SIP Softphone with real ip ( X201 ) in Pismo Beach.

X300 needs to use a stun server to connect to Asterisk
and can hear all the menus and leave voice mails. X300
is setup for NAT in Asterisk config.

X201 and X202 do not need stun server and are not
behind NATS and can call each other and get 2 way voice

The probem happens when I try to make a call between
X300 and X201 or X202. What happens is the SIP signalling
all works and it says there is a connect call, but the voice
paths are not working. For example, X300 dials X201 and X201
sees and incoming call from X300 and answers. Connected call
message and then no voice path.

If X300 can connect to Asterisk and hear and record voice mails
it should get 2 way voice path when calling another extension?

Both X300 and X201 are being connected together at the Asterisk
server right?

hehe Someone please bail me out.

I’m assuming you’re using * 1.4.x: check the value, in sip.conf, of the parameter canreinvite, I would try to set canreinvite=no for X300 and canreinvite=nonat for X20x, also try activate the rtp debug with the cli command “rtp debug on” and see if rtp packets are coming or not when you call from X300 to X20x.

Let me know.


Marco Bruni

I would argue that x201, and x202 both need to use STUN as well.

The communications between any SIP endpoint that may traverse a NAT is best done with STUN support. It doesn’t matter if it’s phone to Asterisk, phone to phone, or Asterisk to phone.

It’s true that x201, and x202 don’t need STUN support to call each other or the Asterisk server. But if they’re going to be part of a call that would involve NAT, it might be necessary.

Thank you everyone. I have solved the problem
after carefully trying all your suggestions. The issue
was that the asterisk box ( being behind a NAT AND
firewall itself ) did not have a whole open wide enough
for rtp ports it needed. The rtp debug was key.

This is not expected because x201 and x202 could
talk with no problem. Anyhow, we can call this particular
issue popped.

I have a few other issues but will try to solved before posting
for help.