Asterisk uses different ports than thoose in the rtp.conf


I’m having a weird problem with Asterisk 1.2.13, running on a Linux box.
I have a firewall, which lets any needed port through the ports 30000…32000 for RTP, as specified in rtp.conf:


BUT: the RTP stream is often sent through a port which is not in this range!!!
So there is often no audio!

Is this a bug?
There is no NAT just a firewall.

Thanks in advance!


RTP port settings is a device thing… check the device setup…

by default devices use different ranges…
go set the range to what you want your devices to use


Thanks for your post! Unfortunately there is no device on the other end of the SIP connection but a SIP provider:
Can I still force the use of a specified port range somehow?
(I don’t think voipdiscount will change his settings, just for me ! :frowning: )


I doubt they will. Ask them if there is a specific range that you can use so you have a limited amount of ports open.


Thanks, I’ll for sure ask them. Too bad, until know they seem to use just a random port from port 1024 upwards.
Maybe someone knows a possibility to enforce the use of a port range?
I know if they are using a sip aware firewall it will probably not work, but maybe they have just left any port in a wide range open. (Which is probably quite uncommon.)
Or I should just use a STUN enabled SIP proxy in front of Asterisk?
GRR… Things getting complicated. :confused:



GRR… Things getting complicated. :confused:


Welcome to Asterisk. After you bang your head against the wall for a while you will figure things out.

this helped! A lot!