Asterisk SIP Integration with Avaya SES


#1

Dear All expert,
When i am trying outbound call from my asterisk to Avaya SES server between sip trunking between both system so i am facing the following issue.

– Called IPTEL/4545
– Got SIP response 483 “Too Many Hops” back from 10.9.44.28
== Everyone is busy/congested at this time (1:0/0/1)
– Auto fallthrough, channel ‘SIP/1214-00000007’ status is ‘CHANUNAVAIL’

sip.conf
[Avaya]
type=friend
context=call_manager
host=10.9.44.28
qualify=yes
disallow=all
allow=all
dtmfmode=rfc2833
nat=yes

extensions.conf
exten => 4545,1,Dial(SIP/Avaya/${EXTEN}4545)

And I have tested my asterisk with Avaya IP Office from same outbound call to my asterisk on Avaya IP Office Sip Trunk working are fine and Asterisk to Asterisk also working fine but unfortunately not success with Avaya SES 6.3.

Please advise and thanks for your support in advance.


#2

Does Avaya require asterisk registration???
How about sip show peers command?


#3

Rmcgrath thanks for your swift response,
yes my sip show peers are 100% reachable with avaya as shown details below.
peer ‘Avaya’ is now Reachable. (2ms / 2000ms) and also 200 OK on avaya with UP.

Please advise.


#4

The error implies a routing loop.


#5

David thanks for your prompt response,
Dear could you please share more where we should check or change routing loop in asterisk or avaya end.


#6

David thanks for your prompt response,
Dear could you please share more where we should check or change routing loop in asterisk or avaya end.

Please advise when you free and thanks in advance.


#7

A routing loop means that the Avaya doesn’t think the called number belongs to it, but what it sends it to thinks it does belong to it. That something will not be the Astersik, as, as a back to back user agent, Asterisk doesn’t maintain the hop count. A such you need to solve this problem on the Avaya.

(Although it may be due to your sending a wrong number to the Avaya, it is still a configuration fault in the Avaya for it to send a wrong number into a routing loop.


#8

In Avaya end they have defined 4545 number on this call routing and i am also dialing same from Asterisk.
As you can find below my asterisk dial exten below.

Multiple testing:
#1- exten => _45XX,1,Dial(SIP/Avaya/${EXTEN})
#2- exten => _xxxx,1,Dial(SIP/Avaya/4545)
#3- exten => 4545,1,Dial(SIP/Avaya/4545)

And so on available different pattern as above.


#9

[quote=“arshad.hussain, post:1, topic:68167”]
SIP response 483 “Too Many Hops” back from
[/quote] How about to enable srvlookup=yes on SIP configuration?


#10

Things to try:
sip.conf
Change type=friend to type=peer
Add ipaddr=10.9.44.28
Add port=5060

extensions.conf
Change SIP/Avaya/${EXTEN} to SIP/${EXTEN}@Avaya


#11

Yes its enable in sip.conf
srvlookup=yes


#12

Well, wasn’t on your paste configuration, anyway how about;
maxforwards=70 ; Setting for the SIP Max-Forwards: header (loop prevention)
; Default value is 70


#13

mkozusnik, thanks for your response,
i change SIP/Avaya/${EXTEN} to SIP/${EXTEN}@Avaya
but same result along with changes sip.conf as per your instruction.


#14

Already shared on top.
sip.conf
[Avaya]
type=friend
context=call_manager
host=10.9.44.28
qualify=yes
disallow=all
allow=all
dtmfmode=rfc2833
nat=yes

extensions.conf
exten => 4545,1,Dial(SIP/Avaya/${EXTEN}4545)

and use sip set debug on and i check maxforward=70 set in my asterisk.

Retransmitting #4 (NAT) to 192.168.11.101:5060:
OPTIONS sip:192.168.11.101 SIP/2.0
Via: SIP/2.0/UDP 10.9.44.28:5060;branch=z9hG4bK380df7a2;rport
Max-Forwards: 70

i can share more settings setting whatever you required.


#15

Well as no way with to solve with Asterisk parameters, problems becomes from a networking issue and it seem you have to review your networking between Asterisk and Avaya.


#16

Dear Everyone,

Thanks for your prompt responses.
Issue has been resolved.

At Avaya end they have create new entity for my Asterisk SIP Trunk (Separated and New) then issue resolved no Asterisk issue and my all Asterisk configuration perfect for Avaya SES SIP Trunk.

Thanks again.