Asterisk sip auto-dial

I’m trying to place a test call through asterisk .call files. I’m a newbie so the problem shouldn’t be anything horribly complex. But nonetheless, I’ve relentlessly tried to pursue this problem with a number of configuration changes.

Version: asterisk-1.2.16
For reference: I changed my phone number to 8155551212 for the purpose of concealing my identity.

sip.conf:

extensions.conf:

output:

Hi

[quote][outgoing]

exten => s,2,Dial(SIP/sip.inphonex.com/8155551212)

exten => s,3,Wait(1)

exten => s,4,Echo

exten => s,5,HangUp() [/quote]

where is
exten => s,1,
?

Ian

I assume you’re alluding to the fact that extension s1 does not exist. I’ve changed it and here is the new output:

[quote] – Attempting call on SIP/18155551212@sip.inphonex.com for s@outgoing:1 (Retry 1)
> Channel SIP/sip.inphonex.com-081ba580 was answered.
– Executing Dial(“SIP/sip.inphonex.com-081ba580”, “SIP/sip.inphonex.com/8155551212”) in new stack
– Called sip.inphonex.com/8155551212
– Got SIP response 484 “Address Incomplete” back from 208.239.76.163
== No one is available to answer at this time (1:0/0/0)
– Executing Wait(“SIP/sip.inphonex.com-081ba580”, “1”) in new stack
– Executing Echo(“SIP/sip.inphonex.com-081ba580”, “”) in new stack
== Spawn extension (outgoing, s, 3) exited non-zero on 'SIP/sip.inphonex.com-081ba580’
Mar 23 18:26:34 NOTICE[13656]: pbx_spool.c:279 attempt_thread: Call completed to SIP/18154885388@sip.inphonex.com

[/quote]

EDIT: forgot to reload extensions

A post was split to a new topic: Asterisk Support of HackRF

Start a new thread. I’m closing this one.

No need to close, I split it out to a new topic.