Asterisk returning Public IP in contact

Asterisk is returning it’s Public IP in contact. Is there a way to force Asterisk to send Private IP?

Thank you

Which channel technology drive are you using? For chan_sip, setting localnets appropriately should achieve this.

Hello, Sorry I left that important information out; I am using Asterisk 15.3, and chan_pjsip.

Thank you,

If you are referring to the response to an incoming REGISTER there’s no current way to enable this. You can follow the issue[1] so you know when that changes.

If you are referring to Asterisk sending an outgoing REGISTER then the local_net and external_signaling_address on the transport control that.

[1] https://issues.asterisk.org/jira/browse/ASTERISK-28502