Asterisk ODBC-MySQL

Hi!

I have a little problem with the Asterisk odbc to MySQL connection. I would like to create a dynamic realtime system to manage the SIP users/pears, but i cant figure out what did I wrong. :cry:

At first I set the server odbc connection.

odbc.ini

[asterisk-connector]
Description           = MySQL connection to 'asterisk' database
Driver                = MySQL
Database              = DBSchemaName
Server                = DBServerName
UserName              = DBUserName
Password              = DBUserPass
Port                  = 3306

odbcinist.ini

[MySQL]
Description	= ODBC for MySQL
Driver		= /usr/lib/libmyodbc5.so
Setup		= /usr/lib/libodbcmyS.so
Driver64	= /usr/lib64/libmyodbc5.so
Setup64		= /usr/lib64/libodbcmyS.so
FileUsage	= 1

…and check the connection like this: isql asterisk-conenctor DBUserName DBUserPass -v
…and I could connect.

At second I set the Asterisk odbc connecter config file.

res_odbc.conf

[asterisk]
enabled => yes
dsn => asterisk-connector
username => DBUserName
pasword => DBUserPass
pre-connect => yes
limit => 1

Next I configured the extconfig.conf

extconfig.conf

sippeers => odbc,DBSchemaName,DBTalbeName
sipusers => odbc,DBSchemaName,DBTableName

Next I set the rtcachefriends=yes in the sip.conf.

At last i tried to use it all but i couldn’t.

I got this Warning message:

What did I wrong? Any suggestion or idea :question:
Thanks!

[quote]res_odbc.conf

[asterisk]
enabled => yes
dsn => asterisk-connector
username => DBUserName
pasword => DBUserPass
pre-connect => yes
limit => 1

Next I configured the extconfig.conf

extconfig.conf

sippeers => odbc,DBSchemaName,DBTalbeName sipusers => odbc,DBSchemaName,DBTableName [/quote]

Your “extconfig.conf” file should reference the database context in “res_odbc.conf”. Change "DBSchemaName " to “asterisk”.

Thank you, but it unfortunately doesn’t change anything.

The odbc connecting always crash with that problem.

I’v installed everything and did it step by step with guides but still doens’t work.

Once I will do this from the beginning with clear mind, and I will share the result. :unamused:

Peace!