Asterisk not accepting dtmf keys from twinkle in ivr menus

I got Asterisk 1.8 configured and running with various IVR menus.
They are working fine over a pri line. But when im trying to use a softphone like ekiga or twinkle, there is no DTMF getting recognized. Im attaching my sip configuration.
please let me know if i can make any changes and get it working[code][general]
context=default ; Default context for incoming calls
allowoverlap=no ; Disable overlap dialing support. (Default is yes)
udpbindaddr= ; IP address to bind UDP listen socket to ( binds to all)
tcpenable=no ; Enable server for incoming TCP connections (default is no)
tcpbindaddr= ; IP address for TCP server to bind to ( binds to all interfaces)
srvlookup=yes ; Enable DNS SRV lookups on outbound calls
; limits the other side’s codec choice to exactly what we prefer.

disallow=all ; First disallow all codecs
allow=ulaw ; Allow codecs in order of preference
;allow=ilbc ; see doc/rtp-packetization for framing options
;dtmfmode = auto ; Set default dtmfmode for sending DTMF. Default: rfc2833

basic-options ; a template

natted-phone ; another template inheriting basic-options

public-phone ; another template inheriting basic-options

my-codecs ; a template for my preferred codecs

ulaw-phone ; and another one for ulaw-only
regexten=1234 ; When they register, create extension 1234
callerid=“Jane Smith” <5678>
host=dynamic ; This device needs to register
nat=yes ; X-Lite is behind a NAT router
;directmedia=no ; Typically set to NO if behind NAT
allow=gsm ; GSM consumes far less bandwidth than ulaw
mailbox=1234@default,1233@default ; Subscribe to status of multiple mailboxes
registertrying=yes ; Send a 100 Trying when the device registers.[/code]

Set dtmfmode=rfc2833 for the softphone extension in sip.conf and set the same thing in the softphone setting. If DTMF is not working after that, double check you have RFC2833 set for the DTMF sending protocol in Asterisk and Softphone.

i tried the sip service again with the dtmfmode changes in asterisk and twinkle…
I didn’t have any success…
is there a any way i can check the debug info and find what the actual problem is…
What are the file i can check… i havnt seen any info in asterisk logs or twinkle logs…
can anyone point out any file that im missing to check…
For asterisk i checked the CLI info and system messages.
for twinkle i checked in the twinkle.log present in the .twinkle folder…

Did you try any other SoftPhones that work on Windows (Zoiper is very nice for these sorts of tests)?

i tried linux version of zoiper.
it is working fine with the dtmf tones…

One problem still there is, similar to twinkle, when the call is in progress and if try to disconnect the call, the app is getting hanged.

I have the same problem with Twinkle on OpenSuse 11.3. The software hangs almost on every call …

Please try to install Ekiga - I find it very usefull and quite stable. Just be carefull on the first run - don’t forget to select the option that you do not want to use the Ekiga service!