Asterisk, No SIP voice on incoming/outgoing calls


#1

Below is my sip.conf, I would appreciate if anyone can help me.

[root@gsupbx1 asterisk]# cat sip.conf
[general]

bindport=5060
bindaddr=0.0.0.0
allowguest=yes
allow=ulaw
context=default

bindaddr=10.1.50.252
externip=x.x.x.x
localnet=10.1.50.0/255.255.255.0

nat=yes

#include sip.auto.conf

[bandwidth-1]
host=x.x.x.x
port=5060
type=peer
allow=ulaw
dtmfmode=rfc2833
reinvite=yes
canreinvite=no
context=from-pstn
nat=no

[bandwidth-2]
host=x.x.x.x
port=5060
type=peer
allow=ulaw
dtmfmode=rfc2833
reinvite=yes
canreinvite=no
context=from-pstn
nat=no

[root@gsupbx1 asterisk]# cat rtp.conf
;
; RTP Configuration
;
[general]
;
; RTP start and RTP end configure start and end addresses
;
; Defaults are rtpstart=5000 and rtpend=31000
;
rtpstart=10000
rtpend=20000
;
; Whether to enable or disable UDP checksums on RTP traffic
;
;rtpchecksums=no
;
; The amount of time a DTMF digit with no ‘end’ marker should be
; allowed to continue (in ‘samples’, 1/8000 of a second)
;
;dtmftimeout=3000
; rtcpinterval = 5000 ; Milliseconds between rtcp reports
;(min 500, max 60000, default 5000)
;
; Enable strict RTP protection. This will drop RTP packets that
; do not come from the source of the RTP stream. This option is
; disabled by default.
; strictrtp=yes
;
; Number of packets containing consecutive sequence values needed
; to change the RTP source socket address. This option only comes
; into play while using strictrtp=yes. Consider changing this value
; if rtp packets are dropped from one or both ends after a call is
; connected. This option is set to 4 by default.
; probation=8


#2

Dont know what version of Asterisk are you using, but this parameters will help if you re using Asterisk 13 > higher version


#3

I am using Asterisk 1.8.28-cert5 . And i don’t see chan_sip in my etc/asterisk.


#4

That version hasn’t been supported for many years. He meant the configuration file for chan_sip.

However, I think the configuration error is more likely to be on your NAT router.

reinvite is not a parameter.
canreinvite is now called directmedia, and was even for 1.8.
The “yes” value of nat is deprecated and generally does more than is needed in simple NAT configuration.
allow without disallow has no effect as all codecs are already enabled.


#5

I did the mentioned changes but still not hearing any voice on any of the incoming or outgoing calls.


#6

The only really important change was the NAT rules. How did you change those.

The secondary change needed was to upgrade to a supported version; did you do that.

The remaining issues were either harmless or reduce security.


#7

Below is the config after i made the changes:

[general]

context=internal
allowguest=no
allowoverlap=no
alwaysauthreject=yes

bindaddr=10.1.50.252
externip=x.x.x.x
localnet=10.1.50.0/255.255.255.0

[bandwidth-1]
host=x.x.x.x
port=5060
type=peer
disallow=all
allow=ulaw
dtmfmode=rfc2833
reinvite=yes
directmedia=no
context=from-pstn
nat=yes

[bandwidth-2]
host=x.x.x.x
port=5060
type=peer
disallow=all
allow=ulaw
dtmfmode=rfc2833
reinvite=yes
directmedia=no
context=from-pstn
nat=yes


#8

What is the make, model, and configuration of your router?


#9

[root@gsupbx1 ~]# dmidecode -t chassis

dmidecode 2.12-dmifs

SMBIOS 2.7 present.

Handle 0x0003, DMI type 3, 22 bytes
Chassis Information
Manufacturer: Supermicro
Type: Desktop
Lock: Not Present
Version: 0123456789
Serial Number: 0123456789
Asset Tag: To Be Filled By O.E.M.
Boot-up State: Safe
Power Supply State: Safe
Thermal State: Safe
Security Status: None
OEM Information: 0x00000000
Height: Unspecified
Number Of Power Cords: 1
Contained Elements: 0
SKU Number: To be filled by O.E.M.

[root@gsupbx1 ~]# dmidecode -t 1

dmidecode 2.12-dmifs

SMBIOS 2.7 present.

Handle 0x0001, DMI type 1, 27 bytes
System Information
Manufacturer: Supermicro
Product Name: X9SCI/X9SCA
Version: 0123456789
Serial Number: 0123456789
UUID: 7B902500-E633-0706-0025-907B33E60E0F
Wake-up Type: Power Switch
SKU Number: To be filled by O.E.M.
Family: To be filled by O.E.M.


#10

How has it been configured to handle the RTP streams?


#11

[root@gsupbx1 ~]# cd /etc/asterisk
[root@gsupbx1 asterisk]# ls
adsi.conf cdr_mysql.conf cid.auto.conf extensions.lua jingle.conf queuerules.conf sip.conf
agents.conf cdr_odbc.conf cli_aliases.conf extensions_minivm.conf logger.conf queues.conf sip.conf-10-27-16.conf
ais.conf cdr_pgsql.conf cli.conf extensions.voiceipgui.conf manager.conf res_config_mysql.conf sip_notify.conf
alarmreceiver.conf cdr_sqlite3_custom.conf cli_permissions.conf features.conf manager.voiceipgui.conf res_config_sqlite.conf skinny.conf
alsa.conf cdr_syslog.conf codecs.conf festival.conf meetme.conf res_curl.conf sla.conf
amd.conf cdr_tds.conf console.conf followme.conf mgcp.conf res_fax.conf smdi.conf
app_mysql.conf cel.conf dbsep.conf func_odbc.conf minivm.conf res_ldap.conf telcordia-1.adsi
asterisk.adsi cel_custom.conf did.auto.conf gtalk.conf misdn.conf res_odbc.conf udptl.conf
asterisk.conf cel_odbc.conf dnsmgr.conf h323.conf modules.conf res_pgsql.conf unistim.conf
calendar.conf cel_pgsql.conf dsp.conf http.conf musiconhold.conf res_pktccops.conf users.conf
ccss.conf cel_sqlite3_custom.conf dundi.conf iax.auto.conf muted.conf res_snmp.conf voicemail.conf
cdr_adaptive_odbc.conf cel_tds.conf enum.conf iax.conf osp.conf res_stun_monitor.conf vpb.conf
cdr.conf chan_dahdi.conf extconfig.conf iaxprov.conf oss.conf rtp.conf
cdr_custom.conf chan_mobile.conf extensions.ael indications.conf phone.conf say.conf
cdr_manager.conf chan_ooh323.conf extensions.conf jabber.conf phoneprov.conf sip.auto.conf
[root@gsupbx1 asterisk]# cat rtp.conf
;
; RTP Configuration
;
[general]
;
; RTP start and RTP end configure start and end addresses
;
; Defaults are rtpstart=5000 and rtpend=31000
;
rtpstart=10000
rtpend=30000
;
; Whether to enable or disable UDP checksums on RTP traffic
;
;rtpchecksums=no
;
; The amount of time a DTMF digit with no ‘end’ marker should be
; allowed to continue (in ‘samples’, 1/8000 of a second)
;
;dtmftimeout=3000
; rtcpinterval = 5000 ; Milliseconds between rtcp reports
;(min 500, max 60000, default 5000)
;
; Enable strict RTP protection. This will drop RTP packets that
; do not come from the source of the RTP stream. This option is
; disabled by default.
; strictrtp=yes
;
; Number of packets containing consecutive sequence values needed
; to change the RTP source socket address. This option only comes
; into play while using strictrtp=yes. Consider changing this value
; if rtp packets are dropped from one or both ends after a call is
; connected. This option is set to 4 by default.
; probation=8


#12

Can anyone please us ?


#13

Still waiting for information on what makes you think the router will handle the RTP streams correctly.


#14

All the asterisk configs are located in the asterisk. We never configured any rtp or any other voice protocol in the router.


#15

You need to do so, or there needs to be something enabled in the router that will do so automatically.


#16

[quote=“david551, post:13, topic:78948”]
RTP streams
Yeah i looked at the router and we are not blocking anything at all and there was no change in the router or in the asterisk itself. At the first phones didn’t have dial tone, but when we restart the asterisk server the dial was up and phones are ringing but no sound or voice on any of the calls.


#17

How does the router know how to translate the addresses on inbound RTP?


#18

It’s one to one Nat.


#19

I just upgrade to Asterisk 13 and now all my phones are showing offline unknown, Anyone can help please ?

[general]

allowoverlap=no ; Disable overlap dialing support. (Default is yes)
;allowtransfer=no ; Disable all transfers (unless enabled in peers or users)
; Default is enabled. The Dial() options ‘t’ and ‘T’ are not
; related as to whether SIP transfers are allowed or not.
;realm=mydomain.tld ; Realm for digest authentication
; defaults to “asterisk”. If you set a system name in
; asterisk.conf, it defaults to that system name
; Realms MUST be globally unique according to RFC 3261
; Set this to your host name or domain name
;udpbindaddr=0.0.0.0 ; IP address to bind UDP listen socket to (0.0.0.0 binds to all)
; Optionally add a port number, 192.168.1.1:5062 (default is port 5060)

externip=100.43.28.204
localhost=10.1.50.252

#include sip_custom.conf

[bandwidth-1]
host=216.82.224.202
port=5060
type=peer
allow=ulaw
dtmfmode=rfc2833
reinvite=yes
canreinvite=no
nat=force_rport,comedia
context=from-pstn
insecure=invite,port

[bandwidth-2]
host=216.82.225.202
port=5060
type=peer
allow=ulaw
dtmfmode=rfc2833
reinvite=yes
canreinvite=no
nat=force_rport,comedia
context=from-pstn
insecure=invite,port


#20

There are some deprecated options and other unknown options on your sip configuration file, also why are you including sip custom.conf file ?