Asterisk does not detect Flash Hook


I am using a GXW4108 configured with SIP accounts in Asterisk, and analog lines connected to FXOs ports. I’d to know if we can use a asterisk function to “send a flash” or recognize it and pass it to the Gateway.

I already tried using Flash() but it didn’t worked, since it flashes a DAHDI trunk and i’m using SIP trunks, also tried with SendDTMF(“F”) without success (asterisk seems to ignore it but return no error)

The current scenario is:
Softphone (linphone) registred with a SIP account (101) dial to the Gateway line (1001) and hear the dial tone, then send DTMF with the external number I really want to call.
The call is established and I want to send a flash to put this call in wait (or answer another incoming call)

In my sip.conf both 101 and 1001 sip accounts are using

And my extensions.conf

exten => s,1,MixMonitor(${ARG2}out.wav)
exten => s,n,Wait(5)
exten => s,n,GotoIf($["${ARG1}"="N"]?None)
exten => s,n,SendDTMF(${ARG1})
exten => s,n,Wait(5)
exten => s,n(None),NoOp(End)

exten => _00X.,1,Set(CallExt=${CUT(EXTEN,\,,1)})
same => n,Set(GLOBAL(FileName)=${CUT(EXTEN,\,,2)})
same => n,Dial(SIP/10${CallExt:1:2},60,M(send^${CallExt:3}^${FileName}))
same => n,Hangup

Thanks in advance

1 Like

I’m currently facing the same problem. We cannot check if our asterisk server is detecting hookflashs.

What fmtp parameter is the gateway sending in the SDP handshake?

If it doesn’t include 16, then you should never expect flash to work.

Also note that RFC 4733 says that event type 16 is deprecated.

RFC 2833 allows, but does not require support for, event type 16.