Asterisk dial music on hold work but i can't change default folder

I can not change the “default” class when I use

exten => 123, 2, Dial(SIP/123,30, m(support))

and in music on hold file i have add support class:


i have make dir support and i have added music files.gsm 8000

Asterisk log when i call user:

    -- Registered SIP '123' at
       > Saved useragent "MicroSIP/3.17.3" for peer 123
  == Using SIP RTP CoS mark 5
    -- Executing [123@internal:1] NoOp("SIP/456-00000410", "123") in new stack
    -- Executing [123@internal:2] Dial("SIP/456-00000410", "SIP/123,30, m") in new stack
  == Using SIP RTP CoS mark 5
    -- Called SIP/123
    -- Started music on hold, class 'default', on SIP/456-00000410
    -- SIP/123-00000411 is ringing

You have a space between your options in your Dial command.

I’d never used the m option to dial before but I just tried it and it worked.

exten => 123,1,Dial(SIP/${EXTEN},30,m(support))

space it is not the issue, issue it is he havent specify the music on hold class name m(support)