Asterisk behind NAT(s)

Hi there, I am new to the forum, so maybe I am posting this were I shouldn’t, so please let me know if this topic does not belong here.

I have a network like the one in the picture The asterisk server registers with the provider. The calls from the analogue phones go through as the end phone rings. The calls appear registered in the provider’s log and are billed according to its duration. However, no sound is heard in any of the phones after picking up.

I have tried to reduce the complexity of the problem and set up a SIP client on a mobile phone, and a softhphone inside the asterisk machine, which registers to the asterisk server. The calls from both clients experience the same behaviour as above.

Googling about the problem, I have learnt that it is common problem related to a natted networks. I have tried including externip and localnet within the [general] context of the sip.conf of the asterisk server, but this produces the asterisk to lose registration with the SIP provider.

I was hope someone can shed some light in this regard.



Show us the sip.conf file and the output of “sip set debug on” when you are doing a call.

Also check that you have port forwarding for the RTP range you are using.