Asterisk and Cisco 2600 with FXO

Hi, I’m having difficulty getting calls to go via asterisk to the cisco gateway and fxo card. my settings are below, and I would appreciate assistance.


!

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
! SIP requires routers to be set to use GMT
clock timezone GMT 0
!

hostname rpstn
!

logging queue-limit 100
enable secret 5 xxxxx
enable password xxxx
!

ip subnet-zero
!

!
snmp-server view all3 ospf.* included
snmp-server community public RO
snmp-server community private view all3 RW
snmp-server community config RW
snmp-server enable traps tty
call rsvp-sync
!

interface FastEthernet0/0
ip address 131.170.68.111 255.255.255.0
duplex auto
speed auto
!

interface Serial0/0
no ip address
shutdown
!

interface Serial0/1
no ip address
shutdown
!

interface Ethernet1/0
no ip address
shutdown
half-duplex
!

ip classless
ip http server
!

voice-port 1/0/0
cptone AU
input gain 10
output attenuation 10
no comfort-noise
! Route all calls into this FXO port on to extension 101
connection plar opx 101
!

voice-port 1/0/1
!

!
mgcp profile default
!

!
!

dial-peer cor custom
!

!
!

dial-peer voice 2 voip
destination-pattern .T
session protocol sipv2
session target ipv4:131.170.68.110:5060
session transport udp
dtmf-relay rtp-nte
codec g711ulaw
!

dial-peer voice 701 pots
destination-pattern 9T
port 1/0/0
forward-digits 7
!

dial-peer voice 702 pots
destination-pattern 04…
port 1/0/0
forward-digits 8
!

gateway
timer receive-rtp 1200
!

sip-ua
retry invite 3
retry response 3
retry bye 3
retry cancel 3
timers trying 1000
sip-server ipv4:131.170.68.110
!

!
line con 0
line aux 0
line vty 0 4
password xxxx
login
!

end


[general]
context=default ; Default context for incoming calls
allowoverlap=no ; Disable overlap dialing support. (Default is yes)
bindport=5060 ; UDP Port to bind to (SIP standard port is 5060)
; bindport is the local UDP port that Asterisk will listen on

bindaddr=0.0.0.0 ; IP address to bind to (0.0.0.0 binds to all)

srvlookup=yes ; Enable DNS SRV lookups on outbound calls
; Note: Asterisk only uses the first host
; in SRV records
; Disabling DNS SRV lookups disables the
; ability to place SIP calls based on domain
; names to some other SIP users on the Internet

disallow=all ; First disallow all codecs
allow=ulaw ; Allow codecs in order of preference
allow=all ; see doc/rtp-packetization for framing options

[authentication]

[131.170.68.111]
context=pstn-incoming
type=friend
host=131.170.68.111 ; IP address of Cisco gateway
dtmfmode=rfc2833
disallow=all
allow=ulaw

[101]
; mac 000D295E4DB7
type=friend
host=dynamic
dtmfmode=rfc2833
nat=no
username=101
secret=101
context=sip
allow=all
canreinvite=no
callerid=“Mark Gregory” <101>
mailbox=101@default

[102]
type=friend
host=dynamic
dtmfmode=rfc2833
nat=no
username=102
secret=102
context=sip
canreinvite=no
callerid=“Mark Gregory” <102>
mailbox=102@default


[general]
static=yes
writeprotect=no
clearglobalvars=no
[globals]
CONSOLE=Console/dsp ; Console interface for demo
IAXINFO=guest ; IAXtel username/password
TRUNK=Zap/g2 ; Trunk interface
TRUNKMSD=1 ; MSD digits to strip (usually 1 or 0)

[default]
include => sip

[pstn-incoming]
include => lan-phones

[sip]
include => lan-phones
include => pstn-outbound

[pstn-outbound]
exten => _04.,1,Dial(SIP/${EXTEN}@131.170.68.111)
exten => _9.,1,Dial(SIP/${EXTEN}@131.170.68.111)

[lan-phones]
exten => 101,1,Verbose(1|Extension 101)
exten => 101,n,Dial(SIP/101,20)
exten => 101,n,Hangup()
exten => 102,1,Verbose(1|Extension 102)
exten => 102,n,Dial(SIP/102,20)
exten => 102,n,Hangup()