Asterisk 13 with odoo integration

Hi Guys
i have asterisk 13 compiled with ./configure --with-pjproject --with-ssl --with-srtp
i have compiled successfully and had service Up

now i try to connect over socket from ODOOO but it give me an error as below:

1 sip peers [Monitored: 0 online, 0 offline Unmonitored: 0 online, 1 offline]
– Remote UNIX connection
== WebSocket connection from xxxx70.10:22181’ for protocol ‘sip’ accepted using version ‘13’
[Aug 3 12:15:53] WARNING[2843]: res_http_websocket.c:497 ws_safe_read: Web socket closed abruptly
== WebSocket connection from ‘xxx70.10:22181’ closed
localhost*CLI>

I’m sure that i followed the same Tutorial of Odoo for that integration :slight_smile: https://www.odoo.com/documentation/user/9.0/crm/leads/voip/setup.html

but still no luck .

again I’m using centos 7 with asterisk 13

cheers

Try use in http.conf;

tlsenable=yes
tlsbindaddr=0.0.0.0:8088
tlscertfile=/path-to/cert.pem
tlsprivatekey=/path-to/privkey.pem

Hi thanks for reply
i already tried that and have the same error
here is my http.conf
[general]
;
enabled=yes
bindaddr= xxx.13.80 ; Replace this with your IP address
bindport= 8088 ; Replace this with the port you want to listen on
tlsenable=yes
tlsbindaddr=0.0.0.0:8088
tlscertfile=/etc/asterisk/keys/asterisk.pem
tlsprivatekey=/etc/asterisk/keys/asterisk.key

and here is netstat
[root@localhost ~]# netstat -ant | grep 8088
tcp 0 0 XXX.13.80:8088 0.0.0.0:* LISTEN
tcp 0 0 XXX.13.80:8088 1XXX.75.28:26402 ESTABLISHED
[root@localhost ~]#

also here is sip.conf :slight_smile:
[general]
realm=xxx13.80 ; Replace this with your IP address
udpbindaddr=xxx.13.80 ; Replace this with your IP address
transport=udp
icesupport = true
stunaddr = stun.l.google.com:19302

[1060] ; This will be WebRTC client
type=friend
username=1060 ; The Auth user for SIP.js
host=dynamic ; Allows any host to register
secret=password ; The SIP Password for SIP.js
encryption=yes ; Tell Asterisk to use encryption for this peer
avpf=yes ; Tell Asterisk to use AVPF for this peer
icesupport=yes ; Tell Asterisk to use ICE for this peer
context=default ; Tell Asterisk which context to use when this peer is dialing
directmedia=no ; Asterisk will relay media for this peer
transport=udp,ws ; Asterisk will allow this peer to register on UDP or WebSockets
force_avp=yes ; Force Asterisk to use avp. Introduced in Asterisk 11.11
dtlsenable=yes ; Tell Asterisk to enable DTLS for this peer
dtlsverify=no ; Tell Asterisk to not verify your DTLS certs
dtlscertfile=/etc/asterisk/keys/asterisk.pem ; Tell Asterisk where your DTLS cert file is
dtlsprivatekey=/etc/asterisk/keys/asterisk.pem ; Tell Asterisk where your DTLS private key is
dtlssetup=actpass ; Tell Asterisk to use actpass SDP parameter when setting up DTLS

where should i look for ?

I found a post on WebRTC which can be important: http://forums.asterisk.org/viewtopic.php?p=214851

One major change is WebRTC won’t work without HTTPS.
According internal security policy Chrome browser does not support getUserMedia() for unsecure pages since version 47. So you will not be able to use microphone if your page is not HTTPS.

regarding to the link that you sent me

i cant even register to the server

does the registration to the server require https also ?

again where should i have a look to figure out the current problem ?

thank you