Asterisk 13.8.5 Server /Google Cloud/ PJSIP / Zoiper5


Asterisk 13.8.5 Server on Centos 7 Server x86_64 stabled, installed and configured for PJSIP and Extensions.Conf files only. I can see the endpoints, aors and auths within the on console, firewall configured for SIP and RTP Traffic plus Media, MaxContacts in PJSIP is set to 1 just for testing, Using Zoiper5 Free Edition for testing and it registers, I can dial my extension from Asterisk Console, Zoiper is open on my mobile and the mobile rings. NICE

I try calling a different extension from the mobile using Zoiper5, the extension shows up available in the console, the other extension will ring but there is no voice. All suggested changes for Zoiper5 was complied with such as sip, rtp, domain, username, password, auth username, caller id name/number, no stun, dtmf rfc-2833, BLF, Force RFC-3264, and no rport. Transport is set for UDP. Any suggestions would be greatly appreciated.



Can you set up an extension that just runs Echo() and call it from the mobile and see if you get audio?
Can you post the pjsip endpoint and transport configurations? Make sure direct_media is off.

You can also do a “pjsip set logger host <ip_address>” for both extensions on the console to look at the INVITE exchanges. In particular, look at the ip addresses in the SDPs and make sure they’re reachable.

I will test and update afterward

Syntax for extensions.conf is simple for testing:

exten => xxxx,1,Dial(PJSIP/xxxx,20,r)
exten => xxxx,4,Hangup






Priority 4 will never be reached, but it would have been redundant even if it was reachable.

What are you referring to pjsip.conf?

Priorities are a concept used in extensions.conf.

That is a typo and thanks it should read n

@gjoseph @david551 interesting results received:

1000/sip:1000@x.x.x.x:23311;transport=UDP;rinstance=5fc6b528c56c7b23 has been created == Endpoint 1000 is now Reachable – Contact 1000/sip:1000@x.x.x.x:23311;transport=UDP;rinstance=5fc6b528c56c7b23 is now Unknown. RTT: 0.000 msec – Added contact ‘sip:1001@x.x.x.x:46849;transport=UDP;rinstance=7759dbbfef6182fb’ to AOR ‘1001’ with expiration of 60 seconds == Contact 1001/sip:1001@x.x.x.x:46849;transport=UDP;rinstance=7759dbbfef6182fb has been created == Endpoint 1001 is now Reachable – Contact 1001/sip:1001@x.x.x.x:46849;transport=UDP;rinstance=7759dbbfef6182fb is now Unknown. RTT: 0.000 msec == Setting global variable ‘SIPDOMAIN’ to ‘x.x.x.x’asterisk (external IP) : …/src/pj/os_core_unix.c:692: pj_thread_this: Assertion `!"Calling pjlib from unknown/external thread. You must " "register external threads with pj_thread_register() " “before calling any pjlib functions.”’ failed.Aborted

Asterisk aborts and I am back at the #prompt and the same happens when I do the echo test, this is all existing on Centos Server 7 x86_64. Any advice would greatly be appreciated.

Thanks in advance and the asterisk version is 13.18.5, not 13.8.5

In general parameters of sip.conf check if direct_media=no
I use this kind of network server with stun enabled.

First, can you try with 13.19.0? There were a few changes in that area since 13.18.5. If you still get the abort, open an issue1 asap and follow the guidelines for getting good backtraces2.

Can I upgrade to 13.19.0 from 13.18.5 without creating another instance
and starting the installation from scratch? Second, was the
install_prereq file updated as this version of asterisk has upgraded a



@lmoraes you have a centos 7 server with 13.18.5 installed in a cloud environment and it does not abort when you place a call using Zoiper?

@gjoseph did as you suggested with the reloading of the module and received the following:

*CLI> module reload
Module ‘’ reloaded successfully.
*CLI> – Reloading module ‘’ (Cryptographic Digital Signatures)

This is a Centos 7 x86_64 Server with Asterisk 13.18.5. Are you still suggesting to upgrade to 13.19.0?

I have an Ubuntu server installed. And doesn’t abort in Zoiper.
If want to contact me.

Skype and e-mail

@lmoraes is your server in the cloud?

yes ejohnson is a cloud in Amazon

@lmoraes are you experiencing sipvicious attacks of your asterisk server behind AWS?

I saw some brute forces attacks, but doesn’t problem to me, in the actual moment I didn’t close my firewall completely yet, but I will do it soon.

@lmoraes The intruder got past AWS IDS and reached your server?

no, only tried to enter, I use a good password and firewall